Voicemeeter or Audio problem after WIN10 update

The Virtual Audio Mixer discussions and support...
Gwydion
Posts: 32
Joined: Wed Aug 02, 2017 5:54 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by Gwydion »

Did you get sorted? Let me know and I can try to help you out. Feel free to join my discord if you are still having problems. Would just need some screenshots to start but I can explain that.

https://discord.gg/ZbjZnh8
xGamerG1rl
Posts: 14
Joined: Fri Feb 15, 2019 9:08 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by xGamerG1rl »

I don't know how... but it works again... :D
I've changed nothing...
Well... Time solves every problem :D Thanks
tgparker2019
Posts: 5
Joined: Sun Jun 09, 2019 10:32 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by tgparker2019 »

Been having problems since April. Re-installed Cable A+B and Banana as per your instructions... Most features working ok.

BUT.

AUDIBILITY "Comp." and "Gate" still not working. Any ideas? any suggestions?
GridMonkey
Posts: 7
Joined: Thu Apr 07, 2016 7:03 am
Location: Albany NY

Re: Voicemeeter or Audio problem after WIN10 update

Post by GridMonkey »

So, I have learned a thing that is relevant to this topic, after beating my head in having the same issues as many.
When you update windows, and it restarts.... It does a form of hibernation then restarts, it does not do a full shutdown and restart. Hibernation breaks some driver power states, audio drivers being one of the ones that sometimes gets broken. It had gotten to the point where i'd update windows uninstall reinstall and be fine, but by forcing a few things here and there i managed to recreate (at least the experience of) the stuttering and "garbage" sounds we all have experienced after a windows update.

A full shutdown sorted it every time.

I uninstalled windows updates, rolled back to February updates on another machine, did a March update, got the audio problem, cold shutdown it was fine, repeated with "big updates" until it was up to date, testing full shutdowns every time after an update finished. It seemed to do the trick. I can't say this will work for everyone/every rig but it's worth it to try a full shutdown first before you rip out all the VB software right after updates and audio is "broken." I cold reboot vs an uninstall reboot reinstall reboot/settings check/re-config may save a few headaches.

Until windows learns to let us deal with our audio the way we wish.... *cough*never*cough* one shutdown/cold boot cycle might save us a few more/settings headaches.

Please back check me, i'm not a programmer and don't know how to read the logs even, just imparting what i have experienced.

Luke
tehchubbyninja
Posts: 3
Joined: Fri Sep 04, 2020 1:20 am

Re: Voicemeeter or Audio problem after WIN10 update

Post by tehchubbyninja »

I uninstalled VB-Cable, and VM Banana but they are still showing in my sound options screen as selectable options for playback, so the uninstall obviously didn't uninstall this. Is there a way to fix this without having to do a system restore?
tehchubbyninja
Posts: 3
Joined: Fri Sep 04, 2020 1:20 am

Re: Voicemeeter or Audio problem after WIN10 update

Post by tehchubbyninja »

Okay, so I've done everything outlined in viewtopic.php?f=6&t=381&p=4302&sid=8a15 ... 5be6#p4302 except for make a system restore because I'm not willing to do that right now. I'd rather give up using this product than lose any data I have right now. VMB STILL isn't working, as now when I talk into my mic, it sounds like I sucked down a balloon full of helium first.

I'm at my wits end with this and just about to say screw it, and uninstall everything for good.
Vincent Burel
Site Admin
Posts: 1365
Joined: Sun Jan 17, 2010 12:01 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by Vincent Burel »

You may check audio device default format, or try to re-install the microphone driver... if it's USB one, you may try to disconnect, reboot. reconnect on different USB port, reboot, test it , disconnect again, reboot, reconnect on previous USB port , reboot...
TestXpress
Posts: 10
Joined: Sat Jul 25, 2020 8:34 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by TestXpress »

After the Win10 2004 update I also hat issues with sound. This time I had some high frequent static noise (couldn't hear it, but Spectralissime visualized it, even if the bus was on mute) and sometimes high frequent, audible artifacts. What fixes this for me was switching the audio settings of ALL devices. E.g. it was on 96 kHz / 24 Bit and changed it everywhere to 48kHz / 24 Bit:
  • Sound Control Panel - Playback - all output devices
  • Sound Control Panel - Recording - all input devices
  • Voicemeeter Settings - Internal SR
  • Control Panels for each Virtual Device and Virtual Audio Cable - Options - Internal Sampling Rate
  • Reboot
I am absolutely sure I hat the same settings for all devices before (96 kHz / 24 Bit), but somehow I had the issues. After switching all settings everything was fine (no high frequent noise and no audible artifacts anymore).

I didn't try yet to switch everything back to 96 kHz / 24 Bit. Would be interesting to know if it works well again. Because... prior to the Win10 Update I did the same vice versa and it also fixed issues back then. So, I assume some internal settings are getting messed up during the update process. And if you change the settings everywhere it will be set correctly again.

[EDIT]
Okay, switching it back unfortunately led to the same issues than before :(
Post Reply