ASIO/Ableton works with Banana but not Potato

The Virtual Audio Mixer discussions and support...
Post Reply
pault1
Posts: 4
Joined: Tue Aug 25, 2020 9:11 pm

ASIO/Ableton works with Banana but not Potato

Post by pault1 »

I'm using a MOTO M2 as the A1 ASIO device. I'm sending channels 7/8, 15/16, and 23/24 to the virtual ASIO driver, and using the Voicemeter (Potato) Insert device in Ableton. When using Banana this setup works flawlessly, but when I switch to Potato it doesn't work at all.

For example, when I set the system audio device to Voicemeter Input (channels 7/8) there is no audio unless I deactivate channels 7/8 in the patch insert settings.

Anyway, the strange thing is that the same settings work in Banana, but I'd really like that third channel available so I can put spotify and desktop audio on separate channels (there's a plugin for spotify called equalify that lets you change the audio device for spotify).

All audio interfaces are set to 24-bit/48KHz in the windows sound control panel. The MOTU ASIO driver is set to 48KHz/128 samples. Here are screencaps of my settings (in Ableton, the input config is using the same set of stereo input channels that the output is using):
ableton_setup.JPG
ableton_setup.JPG (185.57 KiB) Viewed 270 times
potato_setup.jpg
potato_setup.jpg (175.33 KiB) Viewed 270 times
ableton_setup.JPG
ableton_setup.JPG (185.57 KiB) Viewed 270 times
Attachments
moto_setup.JPG
moto_setup.JPG (33.24 KiB) Viewed 270 times
Vincent Burel
Site Admin
Posts: 1322
Joined: Sun Jan 17, 2010 12:01 pm

Re: ASIO/Ableton works with Banana but not Potato

Post by Vincent Burel »

you may ask to Ableton, maybe there is a limitation on channel number on ableton side !?
think about that because some ASIO driver have the 32 channels limitation as parameters in their control panel...
pault1
Posts: 4
Joined: Tue Aug 25, 2020 9:11 pm

Re: ASIO/Ableton works with Banana but not Potato

Post by pault1 »

There's no problem with the number of channels on Ableton, they appear correctly when using the potato insert virtual ASIO device, and the lower channels don't work either.
Vincent Burel
Site Admin
Posts: 1322
Joined: Sun Jan 17, 2010 12:01 pm

Re: ASIO/Ableton works with Banana but not Potato

Post by Vincent Burel »

ok, there is no audio if ableton does not forward the incoming signal (channel 7.8) . I remind it's an insert.
de-activating PATCH INSERT means the strip does not get audio from INSERT RETURN

check you I/O routing in Abletong then...
pault1
Posts: 4
Joined: Tue Aug 25, 2020 9:11 pm

Re: ASIO/Ableton works with Banana but not Potato

Post by pault1 »

Thanks for replying. The I/O routing in Ableton is configured correctly; that's why it works in voicemeter banana. That's the issue I am having. The setup works perfectly with Banana, but not Potato. If you look at the screenshots I posted of the configuration, it is exactly the same in Banana with the exception of the extra 23/24 channels. The configuration is:

In voicemeter: activate patch insert 7/8, 15/16, 23/24;

In ableton:
  • select voicemeter potato insert as ASIO device;
  • activate stereo inputs 7/8, 15/16, 23/24;
  • activate stereo outputs 7/8, 15/16, 23/24;
  • On an audio track, select External In channel 7/8, and External Out 7/8;
  • Turn on monitoring on the audio track;

When the system output device is Voicemeter Input, this should route the system audio into the audio track in ableton, then from ableton to the Voicemeter VAIO channel in voicemeter. It works in Voicemeter Banana, but not Voicemeter Potato. That's why I'm trying to get some help; it appears that the problem is not with the configuration, but with Voicemeter Potato itself.
Post Reply