Page 1 of 1

Microphone not working with Banana

Posted: Sun Oct 11, 2020 8:59 pm
by oscardelta77
Hello,

When banana is running, voice recognition won't work; the Microphone gets no sound.(microphone on hyperx headset).
Voice recognition works fine when i shut down banana.

I've set microphone as hardware input1
Headset is set as output 1 and soundblaster play!3 set as output2.

Thanks for your help !
Oliver

Re: Microphone not working if banana is running

Posted: Mon Oct 12, 2020 9:28 pm
by oscardelta77
Hi,

So :
- Microphone(WDM) is set as hardware input #1
- VoiceMeeter Output is set as default recording device
- B1 is enabled for harware input #1

Should'nt it work this way ?

Regards,
Oliver.

Re: Microphone not working if banana is running

Posted: Tue Oct 13, 2020 10:41 pm
by oscardelta77
It's still not working :?

Any idea ?

Thanks !

Image

Image

Image

Image

Image

Image

Re: Microphone not working with Banana

Posted: Wed Oct 14, 2020 12:07 am
by Andres
Hi Oliver. ┬┐Have you tried selecting MME interface (instead of WDM) from Hardware Input 1? Could you please provide a screenshot of Voicemeeter System Settings / Options dialog box? Voicemeeter allows you to set WDM Exclusive Mode for Inputs so you could check that too.

Re: Microphone not working with Banana

Posted: Wed Oct 14, 2020 1:24 pm
by sjc-or
I think since virtual devices are only either recording device or playback device at a given time, that you cannot monitor on the same VAIO port as you are recording, rather you would have to monitor the microphone on a different physical port or turn on "listen" in the WIndows dialog box.

At least that is what I'm thinking. I too would like to monitor the input of a given VAIO port to see what my voice sounds like at the final destination rather than monitor through a separate physical port. There are a few threads on this subject on the board that I could find.

Re: Microphone not working with Banana

Posted: Fri Oct 16, 2020 6:29 am
by Vincent Burel
you may check your microphone level is no ZERO and not MUTED

otherwise you may try to select another audio interface for your Microphone.
if WDM does not work, simply use MME.

Re: Microphone not working with Banana

Posted: Wed Apr 07, 2021 10:24 pm
by oscardelta77
Hi there,

Sorry for the delay.

Still no luck !

Level is not ZERO and not MUTED.

I can't change WDM Input Exclusive Mode option, and i can't change Engine Mode too.

I'm running the latest version.

The microphone works fine if i deinstall Banana, so i'm sure it's about a parameter somewhere.

Re: Microphone not working with Banana

Posted: Thu Apr 08, 2021 10:54 am
by oscardelta77
Hi,

i have a settings backup (everything was ok then). If i load tis backup, Input 1 is red (VB audio input) and it's no more in the devices list.

so i've uninstalled Banana.
Now, the mic does not work at all !

Latest drivers are downloaded (Realtek). Wait and see ...