How can I fix huge delay between VBCable Input and Output?

The Virtual Audio Mixer discussions and support...
Post Reply
michmchelge
Posts: 3
Joined: Tue Dec 29, 2020 9:58 am

How can I fix huge delay between VBCable Input and Output?

Post by michmchelge »

I recorded a short video with demonstrating my issue: https://youtu.be/a5mw5QmTGJs

Screenshot of System Settings from Voicemeeter: https://imgur.com/a/vPnS0v1
Default sound devices: https://imgur.com/a/I4ousrc

Actually my goal is to route Discord sounds via VBCable Input to get it in OBS from VBCable Output. To separate this. For twitch streaming. But I have a huge delay between input and output.

You can see I gain my headset mic in first hardware input unit. Thus, now I'm getting the already gained sound stream from my mic in OBS from Voicemeeter Output without delay.

I use MME devices not WDM because of if I use WDM I'm starting to experience audio problems in other applications. But if I use WDM delay is decreases markedly. Some examples:

- Youtube: I open any video then simulately got message like "Something wrong with audio stream" then infinity page reloading.
- Discord: stop hearing anyone in Discord.
- Telegram: I can record a message but can't listen any.

Demonstrating: https://youtu.be/l1ALYuho4C0

Also I can't understand how other described above applications are depends on Voicemeeter settings in this case.

How delay is different if I use all devices as WDM but A1 output as MME (WDM then): https://youtu.be/F7AQKhkmcLw
Andres
Posts: 142
Joined: Fri May 01, 2020 7:25 pm

Re: How can I fix huge delay between VBCable Input and Output?

Post by Andres »

Hi. VB-Cable adds miliseconds of latency (delay). You can try to optimize the configuration to reduce latency. VB-Audio Virtual Cable Control Panel shows you the important parameters (Internal Sampling Rate and Maximum Latency). Try to set Internal SR to the same sampling rate used on VB-Cable Input and Output device properties (Advanced tab). You find the Control Panel in this folder: C:\Program Files\VB\CABLE

If you review the buffer size in your Voicemeeter Settings, MME by default uses 1024 samples vs 512 used by WDM. This contributes to the added latency when using MME. You can try to reduce MME buffer size.

You can select the WDM option for devices at Voicemeeter Hardware Input (the way it appears in your Voicemeeter System Settings screenshot).

When you select the WDM option for Hardware Output devices, Voicemeeter will open a session in Exclusive mode so other applications (Google Chrome for example) could not use the device at the same time. Exclusive mode was designed to reduce latency bypassing some Windows audio components. To avoid the error in Google Chrome you can change your default Windows playback device to Voicemeeter Input and then route that Virtual Input to a hardware output using A1, A2 or A3.

Hope this helps.
michmchelge
Posts: 3
Joined: Tue Dec 29, 2020 9:58 am

Re: How can I fix huge delay between VBCable Input and Output?

Post by michmchelge »

Andres wrote: Thu Dec 31, 2020 12:08 am To avoid the error in Google Chrome you can change your default Windows playback device to Voicemeeter Input and then route that Virtual Input to a hardware output using A1, A2 or A3.

Hope this helps.
Thanks. Set-up the Voicemeeter Input as default playback device solve the problem appeared when all other applications crashed after I chose WDM.

The latency has finally decreased noticeably.
Andres wrote: Thu Dec 31, 2020 12:08 am If you review the buffer size in your Voicemeeter Settings, MME by default uses 1024 samples vs 512 used by WDM. This contributes to the added latency when using MME. You can try to reduce MME buffer size.
I tried this at the time of start the topic but I had sound distortion/crackling on output so the method does not work properly for me.
michmchelge
Posts: 3
Joined: Tue Dec 29, 2020 9:58 am

Re: How can I fix huge delay between VBCable Input and Output?

Post by michmchelge »

Andres wrote: Thu Dec 31, 2020 12:08 am Hi
Do you know why Voicemeeter VAIO and Aux input/output virtual devices only MME not WDM? Is that normally? https://imgur.com/a/Nry61mX
Andres
Posts: 142
Joined: Fri May 01, 2020 7:25 pm

Re: How can I fix huge delay between VBCable Input and Output?

Post by Andres »

Hi. It is not normal. They shouldn't appear on any of the selection lists. They started to appear with Windows 10 20H2 Update. It has been reported to VB-Audio. Please do not use any of them.
Post Reply