Page 1 of 2

Audio stuttering after Windows 10 update

Posted: Thu Aug 13, 2020 3:38 am
by llaffer
(100.98 KiB) Downloaded 111 times
I replied in a previous thread and deleted it to create my own so I don't hijack someone else's thread.

I updated Windows 10 to the latest Feature Update (2004) and was getting audio stuttering in my headset.

I had A1 pointed to a virtual cable and A2 pointed to my headset. Saw that in the previous thread that A1 should be a real device so I swapped them.

A1 was working but when I did a test to see how A2 was working, it was still stuttering as a virtual cable.

Attached is a .zip containing an .m4a file showing what I'm hearing in my recordings.

I attempted to update to the latest version of Banana, fully uninstalling the old app and all virtual cable drivers (one at a time, rebooting each time) and reinstalling them all (again, one at a time, rebooting each time). Are there updated versions of the virtual cable drivers?

Looking at the images posted in the other thread, I'll post screenshots of my information below:


Making these images, I see that Cable B has a higher Internal SR frequency. Would that have anything to do with this?

In Zoom, Skype, etc. where I do the group calls to record, I have Microphone set as "Cable Output" and speaker set as "Cable-B Input" to go into Voice Meeter and be mixed into the two outputs. Cable-A is my default Windows sound when I'm recording so anything that would play from my PC like sound files, etc. would then be sent to both output devices.

Let me know if there are any other questions or need more info to see what's going on. Thanks.

Re: Audio stuttering after Windows 10 update

Posted: Sun Aug 16, 2020 10:36 pm
by GTX
Just to hop onto this thread with the same issue on my end, and to explain my setup and what I've tried as well.

This is only specifically happening with the Virtual Cables, routing them through VoiceMeeter Potato. If I set a program like Spotify to output to Cable A, and then set Cable A to "Listen To This Device" so I can hear it without using VoiceMeeter, I still get the stuttering sound.

I've set all virtual cables to 44100 Hz at a Max Latency of 7168, and in VoiceMeeter I have the defaults set the same as you above (MME 1024, WDM 512, KS 512).

My main Hardware Out is my computer speakers, so actual physical hardware.

Double checked this in Windows settings as well just to make sure everything matches.

Now, I've noticed that if I set WDM (which I use mostly) to a buffer of 2048 Samples in VoiceMeeter, the stuttering goes away. Problem is there is so much delay across the system it's extremely noticeable in all applications (around 125ms delay total).

Reverting back from the Windows 10 v2004 update resolved all issues. I can set buffers to as low as 128 and still operate fine.

Re: Audio stuttering after Windows 10 update

Posted: Mon Aug 17, 2020 1:41 am
by llaffer
I also did a revert in order to get things working again.

I did check the numbers I checked above post-rollback and saw that the "Internal SR" values in all three were the same at 96000 Hz. So I'm wondering if that has anything to do with it. But still would like to hear back from those in the know before I install the update again.

Re: Audio stuttering after Windows 10 update

Posted: Mon Oct 19, 2020 11:18 pm
by skullmonkey
I have the same issue but with different setup.

I use VB-Cable as main source and A-Cable for listening to my friends on discord so I can lower their intensity regardless the Desktop sound.
We stream over OBS Studio. We didnt have any issues 3 months ago when we stop the streams for the summer vacation.

Last two streams we have this problem:
After 12 minutes the first time and after 20 min second time the issue appears, but not in my speakers. I can hear them loud and clear, but on the stream and to the recorded video.
Nothing changes when this happens. Just a normal stream changing scenes.

Hope for a update or fix,

Re: Audio stuttering after Windows 10 update

Posted: Wed Oct 21, 2020 4:12 pm
by llaffer
Any thoughts on this from the dev/support team? It has been several months since I first posted and there has been no response.

I tried to upgrade to 2004 again and getting the same stuttering problems.

In my images above I see a discrepency between the Internal SR rates so thought it may be that.

They are all showing 96000 now and still getting the same thing.

I'll try to uninstall and reinstall the drivers and check the values again.

Re: Audio stuttering after Windows 10 update

Posted: Wed Oct 21, 2020 4:48 pm
by llaffer
I did an uninstall and reinstall (rebooting between each one), then checked that the Internal SR was the same for all drivers, and still had the stuttering.

I've, once again, reverted back to 1909.

Re: Audio stuttering after Windows 10 update

Posted: Fri Oct 23, 2020 3:41 pm
by Vincent Burel
you may try to install latest version:

if the problem remains, post screenshot and explanation related to the audio path having problem.

Re: Audio stuttering after Windows 10 update

Posted: Wed Nov 04, 2020 1:52 pm
by skullmonkey
I downloaded the latest version, installed and I still get Version
This is from VBCABLE_A_B_Driver_Pack43
This is from VBCABLE_A_B_Driver_Pack43
Screenshot_3.png (86.54 KiB) Viewed 1502 times
This is from
This is from
Screenshot_4.png (153.16 KiB) Viewed 1502 times
Am I missing something?

Re: Audio stuttering after Windows 10 update

Posted: Thu Nov 05, 2020 8:58 pm
by Vincent Burel
i was talking about voicemeeter.

Re: Audio stuttering after Windows 10 update

Posted: Wed Nov 25, 2020 6:34 pm
by llaffer
OP here.

I tried the update to Windows 10 2004 (though now it's called 20H2 after another new update on top of the update).

After that update I did a full uninstall of Meeter and all three virtual cables, rebooting after every uninstall. I re-installed them (cables first, one at a time, then rebooting each time, then Meeter and reboot).

Using Meeter Banana and the same thing still happens.

Though the cable installers state the version according to the control panels shows

I did see different SR values for one of the cables so I set them all to be the same. After another reboot no change.

I'm going to have to revert again since I can't podcast in this state. Any other ideas or things to try?