Incoming Streams: -none-

VB-Audio Network Protocol and applications
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Incoming Streams: -none-

Post by Matsumae »

Not sure why this stopped working, but I use VBAN to pass audio back and forth between 2 PCs.

It's been working for at least a few years, but only one of my computers seems to be able to receive audio streams now. I've tried from multiple sources, but the line "Incoming Streams: -none-" never changes, and I am unable to select anything from the "IP Address From:" column.

I tried sending an Outgoing stream back to the same PC, and it doesn't even recognize that.

I've restarted and shut down the pc multiple times. I tried reinstalling voicemeeter, but there's no change.

I really don't want to go back to using a 3.5mm cable to pass the audio, but I don't know what other choice I have if I can't fix this issue.
Vincent Burel
Site Admin
Posts: 1394
Joined: Sun Jan 17, 2010 12:01 pm

Re: Incoming Streams: -none-

Post by Vincent Burel »

you may first check that your PC are seen together with a simple ping (MS-DOS prompt).

if they are seen together, you may check your firewall on receiver side.
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Re: Incoming Streams: -none-

Post by Matsumae »

Was able to successfully send pings from both computers.

Firewall has voicemeeter set to allow.

the only difference is one computer recently updated to windows 10 build 18363,, the PC that is still working is currently still on build 18362.

I tried to roll back using a system restore, but it failed, so I'm not sure if this is definitely the issue.

edit: not a windows conflict. was able to uninstall the windows update back to build 18362. no change to my VBAN issue

I also tried using VBAN receptor to ensure that I can send. Both PC's are able to send an audio stream to my phone.

PC 1, the one having the issue, doesn't receive any audio stream from PC 2 in VBAN receptor.

PC 2 does receive an audio stream from PC 1 with VBAN receptor.
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Re: Incoming Streams: -none-

Post by Matsumae »

I made some progress.

setting the IP to .255 I am able to detect the stream!

Is there no harm in leaving it like this? why does the .109 I've been using for ages no longer work? The IP address of my machine has not changed, I've checked and double checked, .109 should be correct
Vincent Burel
Site Admin
Posts: 1394
Joined: Sun Jan 17, 2010 12:01 pm

Re: Incoming Streams: -none-

Post by Vincent Burel »

Matsumae wrote:setting the IP to .255 I am able to detect the stream!
it means you were not sending the stream to the right ip address (255 = broadcast).
Check your host ip address displayed on the top of the VBAN dialog box to enter right destination address.
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Re: Incoming Streams: -none-

Post by Matsumae »

This is where I'm stuck. ipconfig shows my IP is 192.168.0.109. the top of VBAN confirms this, and the incoming stream is also from 192.168.0.109.

Sending 'to' 192.168.0.109, doesn't work, which confuses me greatly.
Vincent Burel
Site Admin
Posts: 1394
Joined: Sun Jan 17, 2010 12:01 pm

Re: Incoming Streams: -none-

Post by Vincent Burel »

could you post screenshot of your VBAN dialog box for both sides?
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Re: Incoming Streams: -none-

Post by Matsumae »

Im back to tackling this because it seems using the .255 to broadcast is having negative effects on the rest of my network.

this time I've noticed that I'm getting the error for "underrun" on the incoming stream. but only if I set the outgoing stream to .255, and then to the proper address of .108

I'm not sure why the audio stream would be coming in too slowly, but now I have to fix this or not be able to continue using vban
Attachments
main119.png
main119.png (73.51 KiB) Viewed 1804 times
main108.png
main108.png (68.93 KiB) Viewed 1804 times
Matsumae
Posts: 9
Joined: Sun Sep 29, 2019 5:35 pm

Re: Incoming Streams: -none-

Post by Matsumae »

This is what still bothers me the most about this situation. from my first post "I tried sending an Outgoing stream back to the same PC, and it doesn't even recognize that."

what would be preventing the stream from being sent to the same pc? if I can get it to receive from itself it will hopefully allow it to receive from other computers on the network as well
Attachments
none108.png
none108.png (77.82 KiB) Viewed 1800 times
1stream119.png
1stream119.png (85.02 KiB) Viewed 1800 times
Vincent Burel
Site Admin
Posts: 1394
Joined: Sun Jan 17, 2010 12:01 pm

Re: Incoming Streams: -none-

Post by Vincent Burel »

maybe it should work better with the loopback address: 127.0. 0.1
Post Reply