Bad - Choppy Sound Quality

The Virtual Audio Mixer discussions and support...
Brad1022
Posts: 5
Joined: Sat Apr 11, 2020 9:23 pm

Bad - Choppy Sound Quality

Postby Brad1022 » Sun May 10, 2020 7:10 am

Pulling my hair out. I'm trying to DJ stream to Twitch via OBS. Using Banana as the audio interface.

Shure SM57 Mic is plugged into an XLR to USB cord (PnP USB Device)
Virtual DJ main out is to VAC B - Channel 2 is VAC B
all of a sudden ALL sound coming from Voicemeeter Banana is horrible. Re-Mapped everything, No effect.
Bypassed Voicemeeter. Sounds Perfect.
Can anyone provide some insight on what might be going on?
I welcome ANY help. Thanks!

Vincent Burel
Site Admin
Posts: 1197
Joined: Sun Jan 17, 2010 12:01 pm

Re: Bad - Choppy Sound Quality

Postby Vincent Burel » Sun May 10, 2020 10:22 am

yes, this is the main problem on Windows to find the right configuration to have something stable...
please read recommendation on our wellknow topic: viewtopic.php?f=6&t=451

Brad1022
Posts: 5
Joined: Sat Apr 11, 2020 9:23 pm

Re: Bad - Choppy Sound Quality

Postby Brad1022 » Sun May 10, 2020 10:53 pm

I've tried everything in the topic you provided. And NOTHING seems to make any difference. There must be something I'm missing.
1) Checked all settings (They all conform to your suggestions,
2) reassigned the A1 Output devices both ways. All inouts are WDM
So far as I know, I am not using an ASIO device for output at all (Although, I'm on the edge of my understanding here.
3) Stream is stable
4) Set Voicemeeter as default output and recording device
Attached is a shot of the settings.
Attachments
Capture.PNG
Capture.PNG (89.02 KiB) Viewed 348 times

Andres
Posts: 17
Joined: Fri May 01, 2020 7:25 pm

Re: Bad - Choppy Sound Quality

Postby Andres » Mon May 11, 2020 3:39 am

Hi Brad. Looks like you have selected a VB-Audio Virtual Audio Cable as your A1 Output device. It is uncommon. It is preferable to use the speakers (connected to your High Definition Audio Device). According to the System settings image this device (A2 Output) is being used in Shared mode which is also uncommon when WDM is selected. The buffer size is also uncommon: it should be 512 samples (your device shows 1056).
To send audio to another application (OBS for example) you could use B1 o B2 busses which are connected to VoiceMeeter Output and VoiceMeeter Aux Output respectively.
According to your original post you are using a Virtual Audio Cable B as output device in Virtual DJ. Maybe you could use Voicemeeter Banana Virtual Input instead?
All these suggestions are based on assumptions about your setup. It would be useful If you could describe it a little further.

Vincent Burel
Site Admin
Posts: 1197
Joined: Sun Jan 17, 2010 12:01 pm

Re: Bad - Choppy Sound Quality

Postby Vincent Burel » Mon May 11, 2020 1:32 pm

yes, your output A1 is expected to be connected to a physical device (for monitoring and checking the main stream is stable).

Brad1022
Posts: 5
Joined: Sat Apr 11, 2020 9:23 pm

Re: Bad - Choppy Sound Quality

Postby Brad1022 » Mon May 11, 2020 5:47 pm

Thank you for your ongoing assistance Vincent and Andres,

Hopefully I'm making progress. Again, I BARELY understand what we're discussing here. So I appreciate your patience:

I have changed the A! Output to be the WDM Speakers. (No effect. I have also done this before. I've gone back and forth many times since this began)
You mentioned I've got A2 in "Shared Mode" I have no idea where that shows up, how I did that, or how to turn it off. It does suggest the cause of ongoing echoing issues. Can you tell me how to change that?
I see the buffer size to which you are referring (under MME, whatever that means) But I don't know how to change it.
Lastly, you suggested that instead of using my virtual cable for an output device, I could use Voicemeeter Banana Virtual Input instead. Forgive my ignorance, but, is that a typo? do you mean Voicemeeter Banana Virtual Output? And where do I find that?
thanks again, you guys must think I'm an idiot.
Attachments
Capture.PNG
Capture.PNG (86.09 KiB) Viewed 326 times

Vincent Burel
Site Admin
Posts: 1197
Joined: Sun Jan 17, 2010 12:01 pm

Re: Bad - Choppy Sound Quality

Postby Vincent Burel » Mon May 11, 2020 6:20 pm

BTW: the screenshot showing "Voicemeeter input (VB-Audio Cable A)" means there is a mess in your audio driver.
please read this topic and consider re-installign Voicemeeter correctly:
viewtopic.php?f=7&t=688

Andres
Posts: 17
Joined: Fri May 01, 2020 7:25 pm

Re: Bad - Choppy Sound Quality

Postby Andres » Mon May 11, 2020 7:25 pm

We all are learning and fortunately this forum exists to help each other.
As Vincent said:
Vincent Burel wrote:yes, this is the main problem on Windows to fidn the right configuration to have something stable...

so you have to take some steps to find the right configuration of Voicemeeter on your PC. Let's try to do this one step at a time.

Brad1022 wrote: I have changed the A! Output to be the WDM Speakers. (No effect. I have also done this before. I've gone back and forth many times since this began)
You mentioned I've got A2 in "Shared Mode" I have no idea where that shows up, how I did that, or how to turn it off. It does suggest the cause of ongoing echoing issues. Can you tell me how to change that?

The S at the end of the OUT A1 Main Device line indicates that Voicemeeter is using the device in Shared Mode.
vmsettings.png
vmsettings.png (75.3 KiB) Viewed 319 times

You can check the Properties of your Speakers in the Playback tab of the Sound Control Panel and make sure that the option "Allow applications to take exclusive control of this device" is enabled.
settings.png
settings.png (175.9 KiB) Viewed 319 times

Another step that could be useful is to set the Sampling Rate (SR) uniformly across devices and applications. Voicemeeter tries to use the Preferred Main SampleRate (in blue) and you could choose the same sampling rate in the Advanced tab of the Properties window of your Speakers. You could try with 24-bit, 48000 Hz.
Brad1022 wrote:Lastly, you suggested that instead of using my virtual cable for an output device, I could use Voicemeeter Banana Virtual Input instead. Forgive my ignorance, but, is that a typo? do you mean Voicemeeter Banana Virtual Output? And where do I find that?

According to Vincent's suggestion you should check the installation of Voicemeeter in your PC before continuing with this case.
Hope this helps.

Brad1022
Posts: 5
Joined: Sat Apr 11, 2020 9:23 pm

Re: Bad - Choppy Sound Quality

Postby Brad1022 » Thu May 14, 2020 7:27 pm

OK, I am happy to report that I am now getting good sound! HOORAY!! Thanks Vincent! I made the changes to the speakers as suggested.

@ questions remain:
1) I see that my Virtual Audio Cables are in Shared mode. How do I get things OUT of shared mode
2) I am noticing a sort of echo when I use my mic. I assume this is related to the shared mode. If not, I'd love any insight on that.

Thanks again!

Andres
Posts: 17
Joined: Fri May 01, 2020 7:25 pm

Re: Bad - Choppy Sound Quality

Postby Andres » Thu May 14, 2020 8:47 pm

Brad1022 wrote:@ questions remain:
1) I see that my Virtual Audio Cables are in Shared mode. How do I get things OUT of shared mode
2) I am noticing a sort of echo when I use my mic. I assume this is related to the shared mode. If not, I'd love any insight on that.

Hi Brad. Maybe you could share an image of Voicemeeter to see how is your microphone connected and routed?


Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 7 guests