Page 1 of 1

nanoKONTROL2, MIDI mapping and feedback

Posted: Mon Mar 15, 2021 1:00 pm
by VRPX
Hello everyone,

before the the new midi feedback functionality was added I used Macro Buttons to switch the lightning state of the buttons on my Korg nanoKONTROL2, which worked fine, although a hassle to set it up. Sadly I was not able to get the current state of 'solo' or 'mute'. So of course I was delighted about the added functionality in VoiceMeeter:
4- MIDI mapping: a MIDI output device can be defined to send feedback to the Input MIDI device (‘F’ button activate the feedback process for each control ‘FF’ for double feedback).
So I uninstalled my previous VM installation before installing version 3.0.1.6.

Cleared all Macro Buttons mappings that I set up so it doesn't intervene with the MIDI feedback.

Set up Mappings in VoiceMeeter like so:

Image

It worked out of the box! For that session, at least.

The next day I was still able to control VM with my nanoKONTROL2 as expected, but lightning doesn't lit up anymore - no matter if I set 'F' or 'FF' in the MIDI mapping settings.

Is there a way to fix this?

Re: nanoKONTROL2, MIDI mapping and feedback

Posted: Tue Mar 16, 2021 8:34 am
by Vincent Burel
on my nanoKontrol 2 controller i've never been able to switch on any buttons
even if using MIDI implementation given by Korg with a special MIDI application:
https://www.korg.com/us/support/downloa ... /159/2710/

Maybe this is pending on something or version or USB power or i don't know...

Re: nanoKONTROL2, MIDI mapping and feedback

Posted: Wed Mar 17, 2021 9:14 am
by VRPX
It worked just fine with Macro Buttons.

It's important that you set the Control Mode and LED Mode of your device accordingly.

For that you want to download the nanoKONTROL/KORG USB-MIDI Driver (for Windows 10).
- Keep the device connected. Restart. After the restart, specific nanoKontrol Drivers will be installed. Restart again.
- grab the nanoKONTROL2/KORG KONTROL Editor. Your device should be detected automatically.
- Select 'Communication' -> 'Receive Scene Data'.
- Then click on the top left square on the device.

Control Mode should be: CC
LED Mode should be: External
Image

- Make sure to select 'Communication' -> 'Write Scene Data' so save these settings on the device.

Fun fact:
After installing said USB-MIDI Driver (for Windows 10) it seems that the buttons light up accordingly now. Also my device doesn't show up as nanoKONTROL2, but nanoKONTROL2 1 SLIDER/KNOB and nanoKONTROL2 1 CTRL in VoiceMeeter:
Image

I will keep an eye out if this persists after a reboot.

Re: nanoKONTROL2, MIDI mapping and feedback

Posted: Wed Mar 17, 2021 2:37 pm
by Vincent Burel
maybe there is a conflict with MacroButton if using the same MIDI output device.
normally an output device can be used by a single application...

will check this Korg app soon.

Re: nanoKONTROL2, MIDI mapping and feedback

Posted: Sun Mar 28, 2021 9:38 am
by Emerick_H
Hello,
From my testings I can confirm that this "bug" only happens when macrokeys is using the same output device.
Appart from that, for me everything was working great with the default nanoKontrol2 mapping, I didn't have to use Korg Kontrol Editor.
I exported the default config and attached it to my post if you want to reset to default settings.