Page 1 of 1

Can't handle crackling noises

Posted: Sat Mar 27, 2021 1:57 pm
by Zargan
EDIT: I replaced the first screenshot of voicemeeter settings because I didnt set it back to the default I had it all the time. Hardware Input 2 was empty but there I have "Cable Output WDM" activated to use it for my Firefox Audio. Seems like that this combination makes the most crackling sounds while listening to videos on youtube or so.

Hey guys,

since 2 weeks I have a problem with some weird crackling at irregular intervals. Sometimes its more like a very short "hanging" of the sound, sometimes it sounds like a "crackling"..

I really dont know how zu explain. Mostly its the kind of crackling you can sometimes notice while increasing the volume abruptly from low to 100% while some music is playing. This for example I can reproduce while the sound goes through voicemeeter. Without voicemeeter there is for sure a very quiet, muffled and short sound influence. But this is normal I think. Its anyhow not that "crackling" I notice with voicemeeter on.

I tested it with 3 devices I own. 1x Logitech G430 Headset, 1x Roccat Elo 7.1 USB and my Logitech Z200 Speakers. No differences between them.

My system got fully updated after I had no more ideas. That means Windows Updates, Mainboard Drivers, BIOS. Nothing changed after that.

I also tested different things I could find in the internet:

Everything from viewtopic.php?f=6&t=451&sid=d3fbf449017 ... 768a0f9cbb
and viewtopic.php?f=6&t=442&sid=d3fbf449017 ... 768a0f9cbb

Re-installation I tried about 3 or 4 times now.

Also...
Increasing buffering size makes nothing besides getting more delay. Switching between WDM and MME - same.
Switched the khz in every playback and recordering device to the same setting. Including the internal SR of every virtual cable.

I tried this with 24bit-48khz,24bit-44.1khz and 16bit-44.1khz. No differences. At the moment everything its set to 24bit-44.1khz.
Also I tried a bit with other functions like "set ASIO SR and Buffering ASIO to another value","WDM Input Exclusive Mode","Engine Mode".

I really have absolutly no more idea what I can try.
Voicemeeter-Settings.PNG
Voicemeeter-Settings.PNG (96.22 KiB) Viewed 1294 times
Sound-Recording.PNG
Sound-Recording.PNG (29.76 KiB) Viewed 1299 times
Sound-Playback.PNG
Sound-Playback.PNG (29.65 KiB) Viewed 1299 times
There are only 3 Attachments allowed so I post you here with text how the device manager looks:

Audio, Video and Gamecontroller:
Elo 7.1 USB
High Definition Audio-Device
Logitech G430 Gaming Headset (just plugged it also for another tests. normally its not plugged)
NVIDIA High Definition Audio
NVIDIA Vitrual Audio Device (Wave Extensible) (WDM)
VB-Audio Virtual Cable
VB-Audio VoiceMeeter AUX VAIO
VB-Audio VoiceMeeter VAIO
VB-Audio VoiceMeeter VAIO3

Audio In and Output:
CABLE Input (VB-Audio Virtual Cable)
CABLE Output (VB-Audio Virtual Cable)
Speakers (Elo 7.1 USB)
Speakers (High Definitio Audio Device)
Speakers (Logitech G430 Gaming Headset) (just plugged it also for another tests. normally its not plugged)
Microphone (Elo 7.1 USB)
Microphone (Logitech G430 Gaming Headset)
VoiceMeeter Aux Input (VB-Audio VoiceMeeter AUX VAIO)
VoiceMeeter Aux Output (VB-Audio VoiceMeeter AUX VAIO)
VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)
VoiceMeeter Output (VB-Audio VoiceMeeter VAIO)
VoiceMeeter VAIO3 Input (VB-Audio VoiceMeeter VAIO3)
VoiceMeeter VAIO3 Output (VB-Audio VoiceMeeter VADIO3)


Hopefully there is just a hook or something I did not set correctly. xD
If you need to know somethimg more, please tell me. Im really new in that sound scene. ^^

Thank you very much for every tips that could help me to resolve this.

Greetings,
Flo

Re: Can't handle crackling noises

Posted: Sat Mar 27, 2021 7:14 pm
by Vincent Burel
you may first consider installing latest version
if the problem remains, please post a screenshot of Voicemeeter and it's system settings dialog box (only 2 screenhsot).

then describe the audio path where you get crackling like
Youtube -> Voicemeeter Virtual Input -> Voicemeeter Output A1

and first follow general recommendation on this topic: viewtopic.php?f=6&t=451

Re: Can't handle crackling noises

Posted: Mon Mar 29, 2021 6:22 pm
by Zargan
Hey Vincent,

thanks a lot. =)

Good things first...

After installing the newest version it seems like to be fixed for the 3 virtual inputs. Listened now on every of that inputs for about 5 minutes without a crackling sound or else.

But I noticed that it remains for the "CABLE Output". It doesnt matter on which hardware input it is configured.

It is:
Mozilla Firefox (Youtube) -> CABLE Output (VB-Audio Virtual Cable) -> Voicemeeter Output A1 or A2
Voicemeeter.PNG
Voicemeeter.PNG (202.94 KiB) Viewed 1236 times
Voicemeeter-Settings.PNG
Voicemeeter-Settings.PNG (97.17 KiB) Viewed 1236 times
Thanks again.

Re: Can't handle crackling noises

Posted: Mon Mar 29, 2021 7:43 pm
by Vincent Burel
on voicemeeter side:
try to select the VB-CABLE with another audio interface (if WDM does not work, try KS or MME)

if the problem remains, please, post a readable screenshotof the VBCABLEControlPanel when sound is passing thrue...

Re: Can't handle crackling noises

Posted: Mon Mar 29, 2021 8:46 pm
by Zargan
CABLE_ControlPanel.JPG
CABLE_ControlPanel.JPG (52.61 KiB) Viewed 1229 times

Re: Can't handle crackling noises

Posted: Tue Mar 30, 2021 12:34 pm
by Zargan
sadly I have to return my "ok". =/

It does not happen often but there are some "hanging moments" again over "Voicemeeter AUX". They are rare but they exist. (Maybe every 10-30 Minutes?).

I've set everything back to 44.1khz. So dont wonder that this is changed. Its the same configuration like in the other screenshots but only set everything to 44.1khz.
VB-Cable_AUX.JPG
VB-Cable_AUX.JPG (75.1 KiB) Viewed 1211 times