[SOLVED!] why VMB on Windows 10 turns into static mess

The Virtual Audio Mixer discussions and support...
Post Reply
ShamisOMally
Posts: 6
Joined: Mon Apr 27, 2015 6:55 pm

[SOLVED!] why VMB on Windows 10 turns into static mess

Post by ShamisOMally »

Ok I found out why VMB is turning into complete static mess for sound coming in/out of the program.

If you turn off:
-Allow Applications to take exclusive control
-Give exclusive mode applications priority

This messes up the sound

With my USB mic if I turn off both of those, it turns into a absolute static mess.

Turning that off with my Nvidia HDMI out causes all sound from VMB to become garbled crap.

So THAT is why VMB is having all these audio problems with Windows 10, with windows 7 this was not an issue, with windows 10 it is.

I have hereby SOLVED the static issue I was having with input/outputs.

This is probably something that should be noted. Exclusive mode needs to be checked in device drivers if its enabled in VMB as this was not an issue with Windows 7 when I had it installed (Maybe my hardware is unique/weird?)
Vincent Burel
Site Admin
Posts: 1556
Joined: Sun Jan 17, 2010 12:01 pm

Re: [SOLVED!] why VMB on Windows 10 turns into static mess

Post by Vincent Burel »

This is a problem more pending on hardware configruation and drivers
Unplug USB audio device, can cause different trouble, possibly stopping audio engine or entering in a unstable audio stream.
usually restarting the audio engine (see menu) fix the problem.

The main point with Voicemeeter is to have a stable main ausio stream,
this is given by the output device selected as output A1

you can attach a screenshot of your Voicemeeter System Settings Dialog Box, to let us know more about your configuration...
ShamisOMally
Posts: 6
Joined: Mon Apr 27, 2015 6:55 pm

Re: [SOLVED!] why VMB on Windows 10 turns into static mess

Post by ShamisOMally »

Image

Downside is since figuring this out, setting mic back on to "Allow exclusive" instead of on, I just saw when coming back my mic had errored out, setting WDM to 576 and I'll see if that fixes it
Vincent Burel
Site Admin
Posts: 1556
Joined: Sun Jan 17, 2010 12:01 pm

Re: [SOLVED!] why VMB on Windows 10 turns into static mess

Post by Vincent Burel »

ha, ok , good,
Generally speaking, i recommend to stay in audio engine default mode.
WDM Input Exclusive Mode is not stable in many configurations (BUG in WASAPI - seems to be still there under WIN10).
Engine Mode: Normal or Swift can be more or less adapted, pending on audio device connected to Voicemeeter, but the Normal Mode is expected to work in all configuration cases, the Switf mode can improve the audio stream stability when using low latency but it's not absolute (i mean in some cases, Swift Mode could work not better than Normal mode).
Post Reply