Page 1 of 1

Realtek Digital Output is Shared with wrong Buf

Posted: Mon Mar 13, 2017 11:15 am
by HmpfReally
Hello everybody,
first of all, thanks for your time :)

I reinstalled my Windows 10 Pro 64 Bit System today and got a problem with VoiceMeeter Banana.
I loaded the old config from my pc (but well it also happens if I just reset settings) and my Realtek Digital Output is Shared with a buf of 1056 instead of 512. It's also configurated as ch:8 (before it was 2) and R:24 (before it was 16) and of course Shared (before it wasn't Shared)

Does anybody know how I could use it in exclusive mode? Anything seems to be wrong, but I can't find the error.
I also configurated VoiceMeeter Banana on my 2nd pc, everything works fine, it's in exclusive mode without any settings.
On both PCs I'm using VoiceMeeter Banana and Realtek Digital Output to send my audio to my 2nd (or 1st) pc. =)

Here's a screenshot, it may help


Please, can anybody help me?

Thanks very much
Best regards

Re: Realtek Digital Output is Shared with wrong Buf

Posted: Tue Mar 14, 2017 6:38 am
by Vincent Burel
Check in the realtek control panel, the multichannel configuration of this device.
Check in windows sound dialog box -> playback device -> select your device and click on
- configure button to select stereo or 5.1 etc...
- property button, then advanced tab could let you set the exclusive mode capable...

let us know...

Re: Realtek Digital Output is Shared with wrong Buf

Posted: Thu Mar 16, 2017 10:52 am
by HmpfReally
Soory that I didn't answer, but I needed to figure out some things :)

This was the post I wanted to publish first, let me call it


First of all, thanks for your reply.
The funny thing is, that I fixed it by myself before I red your response.
Everything worked fine for me, the realtek output was 2.1 again in non shared mode.
I made it with the configuration (in my controlpanel) of voicemeeter.

But I have a new problem.
I don't know why but any strange xBox configuration was enabled inGame (this doesn't matter for the problem, but I want to explain it)
I wanted to turn this strange inGame thing off and needed to login. After that my Windows was connected to my Microsoft Account, so not to my local account anymore.
Well this wasn't the problem, because the settings were the same and everything worked perfekt. I made a final test (also reconfigurations of voicemeeter worked fine for me) and remembered, that I was connected to my Microsoft Account instant of my local one.
So I just reloged and after the restart I had the same problem again, as I described before.
I tested to configurate voicemeeter (and all the other audio stuff in my control panel) again, but this didn't help again.
I relog to my Microsoft Account (maybe that would help) but again, it didn't. Both are using the same settings.

The problem is, that I can't configurate my digital out as you could see here: ... c8d617.png
I have also an ASUS Board in my 2nd Pc and there it's the same, the configuration tab is grey, but my 2nd pc is working fine with the optical out (as I said in my post before)

There is also no option in my realtek interface for the optical out. I also configurate the normal realtek audio out (which I don't use) as 2.1 and 5.1, but this doesn't depend to the digital out, so it doesn't helped :(

I really have no idea, please can you may help me?
Isn't there any way to say Voicemeeter that it should use 2.1 in non shared mode? Because it works great if I go directly through the digital out. The sound is great, but if I want to use Voicemeeter it doesn't work.

Here are some screenshots:
digital out from the realtek interface 1st page: ... 113bb2.png
digital out from the realtek interface 2nd page: ... a63409.png
digital out from the realtek interface 3rd page: ... d28195.png

Best regards


Well I "fixed" it finaly by reconfigurate VoiceMeeter Banana as 7.1 and then again as 2.1.
After I done this, the optical Out is detected right in VoiceMeeter, but after one PC rr I need to do it again.
Again for every restart of my pc, but just the optical out is wrong :(

I tried to reinstall the realtek audio drivers and the voicemeeter drivers, but this also doesn't helped.
The "fix" is working, but just till the next restart. If I just let the audio go through the optical out directly, it's working without problems, also after a restart. I got this problems just with VoiceMeeter, but it worked before for about 10 months and it's still working on my 2nd pc, but everything is set up the same like on the 2nd pc and as before the reinstall of Win 10 on my first pc :(

Could you maybe help me?

Thanks and best regards.

Re: Realtek Digital Output is Shared with wrong Buf

Posted: Mon Mar 20, 2017 10:13 pm
by HmpfReally
Does anybody has any idea? everytime I restart my PC I need to configurate it again and sometimes the reconfiguration doesn't work.
I can't stream since about one week + and would be realy happy if anyone has got a solution.

best regards

Re: Realtek Digital Output is Shared with wrong Buf

Posted: Tue Mar 21, 2017 6:16 am
by Vincent Burel
thanks for this interesting report, Realtek Digital output seems to be not well implemented in some cases...
maybe the question is more related to windows or the realtek audio board.
did you talk about this problem to realtek or Microsoft support ?