Voicemeeter or Audio problem after WIN10 update

The Virtual Audio Mixer discussions and support...
robertkjr3d
Posts: 9
Joined: Sat Jul 27, 2019 12:24 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by robertkjr3d »

For me, i tried reinstalling Voicemeeter. I uninstalled and installed the latest version. But still 'Distorted' if I try to use WDM outputs.
Or do you mean you uninstalled the 'win-update'
ReformedDJ
Posts: 4
Joined: Wed Oct 14, 2020 12:56 am

Re: Voicemeeter or Audio problem after WIN10 update

Post by ReformedDJ »

For me, it was just Voicemeet uninstall and re-install. All my devices are MME, I have just had better luck with that. All my settings remained, so it was just the 2 reboots, once after uninstall and once after re-install.
topia
Posts: 5
Joined: Tue Jun 30, 2020 8:53 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by topia »

For me, too. VoiceMeeter reinstalling (with OS restart) is no luck. I'm using ASIO/WDM for all devices, and it works as expected mostly, but when I use iTunes, play with distortion.

a) play with foobar2000 - ok
b) play with foobar2000 and use Google Chrome - ok
c) play with foobar2000 and do something with iTunes - sometimes with distortion, especially scrolling on library
d) play with iTunes - sometimes with distortion

But my CPU utilization is less than 30% in any case, so I suspect VoiceMeeter distortion caused by the rare type (not any) of heavy UI pressure.
robertkjr3d
Posts: 9
Joined: Sat Jul 27, 2019 12:24 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by robertkjr3d »

topia wrote: Mon Jan 18, 2021 11:35 am For me, too. VoiceMeeter reinstalling (with OS restart) is no luck. I'm using ASIO/WDM for all devices, and it works as expected mostly, but when I use iTunes, play with distortion.

a) play with foobar2000 - ok
b) play with foobar2000 and use Google Chrome - ok
c) play with foobar2000 and do something with iTunes - sometimes with distortion, especially scrolling on library
d) play with iTunes - sometimes with distortion

But my CPU utilization is less than 30% in any case, so I suspect VoiceMeeter distortion caused by the rare type (not any) of heavy UI pressure.
itunes--> preferences--> playback has two options... Playback Using --> 'Direct Sound' or 'Windows Audio Session'
'Windows Audio Session' is preferred for quality. I believe. But that might be where your having the issue. Switch to 'Direct Sound'.
Also its not huge but check the 'sample rate'. Don't do something crazy. Itunes is not generally recorded higher than 48hz anyway.
I would say, if your Voicemeeter is set at 24bit, then set it at 24bit. But otherwise keep the bit rate at 16...
topia
Posts: 5
Joined: Tue Jun 30, 2020 8:53 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by topia »

robertkjr3d wrote: Mon Jan 18, 2021 4:59 pm
topia wrote: Mon Jan 18, 2021 11:35 am For me, too. VoiceMeeter reinstalling (with OS restart) is no luck. I'm using ASIO/WDM for all devices, and it works as expected mostly, but when I use iTunes, play with distortion.

a) play with foobar2000 - ok
b) play with foobar2000 and use Google Chrome - ok
c) play with foobar2000 and do something with iTunes - sometimes with distortion, especially scrolling on library
d) play with iTunes - sometimes with distortion

But my CPU utilization is less than 30% in any case, so I suspect VoiceMeeter distortion caused by the rare type (not any) of heavy UI pressure.
itunes--> preferences--> playback has two options... Playback Using --> 'Direct Sound' or 'Windows Audio Session'
'Windows Audio Session' is preferred for quality. I believe. But that might be where your having the issue. Switch to 'Direct Sound'.
Also its not huge but check the 'sample rate'. Don't do something crazy. Itunes is not generally recorded higher than 48hz anyway.
I would say, if your Voicemeeter is set at 24bit, then set it at 24bit. But otherwise keep the bit rate at 16...
Thank you for replying, but the playback option is no luck too. I had used WAS-192kHz-24bit without any issues before, and tried DirectSound-44.1kHz-24bit with the same issue. And I think this setting is not effective for (c) - iTunes is playing nothing but working for UI.
zapoqx
Posts: 33
Joined: Fri Nov 25, 2016 10:25 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by zapoqx »

Just saying that I just put the update on and my sound on WDM is perfectly fine, but I use my Realtek as A1 (Built new system a few months back :D ). So things seem to be working so far.

Just remember to do the checks:
If a windows update happens and changes your audio for some reason, ensure you have matching sample rates not just on voicemeeter, but also in the sound panel and the hardware. You wouldn't believe how it would drive me nuts on my old system when sometimes it would change my mic to 8000 hz but still trying to run at 48000 hz in Voicemeeter and I'd sound weird to people. Also, if you have your WDM Buffer changed from Default, ensure that its still working. Sometimes switching the buffer back to default and then finding the right WDM setting again helps (if mainly looking to reduce latency as much as possible from those videos).
robertkjr3d
Posts: 9
Joined: Sat Jul 27, 2019 12:24 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by robertkjr3d »

I've tried setting all outputs to the same 'sample-rates'.
I would really rather the sample-rates be set at 96,000.

I'm in the distortion camp, and tired of this problem popping up over the years. I'm willing to pay real-money. I'm now starting to look at other applications. But there doesn't seem to be great alternatives.
zapoqx
Posts: 33
Joined: Fri Nov 25, 2016 10:25 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by zapoqx »

robertkjr3d wrote: Wed Jan 20, 2021 5:56 pm I've tried setting all outputs to the same 'sample-rates'.
I would really rather the sample-rates be set at 96,000.

I'm in the distortion camp, and tired of this problem popping up over the years. I'm willing to pay real-money. I'm now starting to look at other applications. But there doesn't seem to be great alternatives.
Huh. What are you trying to accomplish at 96000? I believe that ya, everything "should" work (I believe that Vincent states it should support up to 112K in the doc?)
Hmm...
The distortion is from everything or just when you speak or when you listen?
topia
Posts: 5
Joined: Tue Jun 30, 2020 8:53 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by topia »

For me, even use 96kHz and ASIO with 1024 buffer, it has distortion on everything (mic and speaker).
zapoqx wrote: Wed Jan 20, 2021 9:21 pm
robertkjr3d wrote: Wed Jan 20, 2021 5:56 pm I've tried setting all outputs to the same 'sample-rates'.
I would really rather the sample-rates be set at 96,000.

I'm in the distortion camp, and tired of this problem popping up over the years. I'm willing to pay real-money. I'm now starting to look at other applications. But there doesn't seem to be great alternatives.
Huh. What are you trying to accomplish at 96000? I believe that ya, everything "should" work (I believe that Vincent states it should support up to 112K in the doc?)
Hmm...
The distortion is from everything or just when you speak or when you listen?
Vincent Burel
Site Admin
Posts: 1582
Joined: Sun Jan 17, 2010 12:01 pm

Re: Voicemeeter or Audio problem after WIN10 update

Post by Vincent Burel »

Voicemeeter and VB-CABLE can work at 96kHz without problem.

so you recommend to follow recommendations there: viewtopic.php?f=6&t=451
and first validate your output A1 device as explained.

also you may watch this video about how to use an ASIO device correctly with Voicemeeter: https://youtu.be/35N8hkOy8h4
Post Reply