Game Audio Stops Being Read By Voicemeeter

The Virtual Audio Mixer discussions and support...
lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Wed Jun 12, 2019 3:15 pm

Hello, I've set up VoiceMeeter exactly as is in this tutorial: https://www.youtube.com/watch?v=0rRiHuTqcKo and everything appears to work for the most part asides from 1 issue being a specific game I am running called 'Dying Light'. The game is set up like other games I have such as '7 Days to Die' and 'Yu-Gi-Oh! Duel Links', all being routed though WDM: CABLE Output (VB-Audio Virtual Cable) labeled as Game Audio. All games audio settings have also been configured to what should be correct in the Windows App Volume and Device Preferences, being CABLE Input (VB-Audio Virtual Cable).

For both 7 Days and Duel Links the audio works fine, does not cut out, with the visual bar showing the audio on VoiceMeeter and Streamlabs OBS recording the audio. Only in Dying Light during loading screens when I need to click or press the space bar to continue does the audio cut out. The visual bar is no longer showing audio coming through and the recording of audio on Streamlabs OBS cuts out. After the following loading screen the audio returns and so on. I am personally able to hear the game audio constantly through my headphones still as it appears under 'Desktop' - VoiceMeeter VAIO.

I've attempted multiple solutions, all failing to solve the issue, such as choosing KS or MME input/output options, utilizing CABLE-A and B instead on different VoiceMeeter channels, toggling on Auto Restart Audio Engine, Restarting the PC after all connections.
Only luck I've had is setting the game audio for Dying Light in the 'App Volume and Device Preferences' to VoiceMeeter Input (VB-Audio VoiceMeeter VAIO), the main input I have set for the PC, and set Streamlabs audio device as the same. I then have to mute the microphone on VoiceMeeter so it does not end up on the same audio track as the game.

Wondering if someone may have another/better idea towards solving this issue as I would seriously prefer not having to mess around with audio configurations every time I want to play a different game for streaming and recording. Just a single set up which works for all games and audio tracks is what I'm looking for. Thanks for taking the time to read and potentially any fixes.

Vincent Burel
Site Admin
Posts: 965
Joined: Sun Jan 17, 2010 12:01 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby Vincent Burel » Wed Jun 19, 2019 7:10 am

if you changed VB-CABLE internal latency, set it back to 7168 sample .

lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Fri Jun 21, 2019 6:16 pm

I have not touched the VB-CABLE internal latency. The only things I have done are in the mentioned Youtube link. The attached image to this message should show the current System Settings.
VB-1.jpg
VB-1.jpg (196.91 KiB) Viewed 2346 times

VB-2.jpg
VB-2.jpg (192.2 KiB) Viewed 2343 times

May I ask what the method would be to change the sample rate to 7168 specifically for the VB-Cable?
Unfortunately this issue occurred once again for another game as well and would imagine it's a situation for multiple games with the loading/cut screens.

Vincent Burel
Site Admin
Posts: 965
Joined: Sun Jan 17, 2010 12:01 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby Vincent Burel » Sun Jun 23, 2019 8:29 am

everything seems to be correct in your configuration.
i guess your game is conencted to first virtual input (that you call "Desktop")...
this Voicemeeter virtual input is well configured with 7168 samples buffer size...

if your game or app cannot playbak in this virtual input device:
1- Or another app is using it in exclusive mode (and prevent other to use it).
2- Or the 7168 samples buffer size is not enough for the game (using buffer size above 2048 samples for example).

for the case #2 you can open the related VBCABLE_ControlPanel (in Voicemeeter folder) to change the internal max latency to 16k for example... then reboot and set the internal latency also to 16k... then see if the audio game comes in...

lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Sun Jun 23, 2019 11:06 am

I have tried testing without exclusive mode first, then with it, and now once again without it. It seemed to make no difference towards the situation I am in. The internal latency in VBCABLE_ControlPanel appears only to go up to 7168 smp, not 16K as you mentioned.
VB-3.jpg
VB-3.jpg (97.27 KiB) Viewed 2331 times

I've tried reducing it to 2048, as well as 4096 in the Cable's Control Panel, and then the 'Desktop' sample rate to match that however the issue remains.
Below are images of VoiceMeeter reading the game audio initially during the cut scene, and then follow up screenshots of the audio cut out with the game transitioning from the cut scene.
VB-6.jpg
VB-6.jpg (196.41 KiB) Viewed 2331 times

VB-5.jpg
VB-5.jpg (78.41 KiB) Viewed 2331 times

The audio system and game running in the above images are working correctly.

lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Sun Jun 23, 2019 11:08 am

Below are screenshots of the game and audio after the cut scene. The audio is cut out from the 'Game Audio' channel, however is still coming through my headphones and can be seen still affecting the audio output of A1 in the Master Section.
VB-7.jpg
VB-7.jpg (196.74 KiB) Viewed 2331 times

VB-4.jpg
VB-4.jpg (98.91 KiB) Viewed 2331 times

Vincent Burel
Site Admin
Posts: 965
Joined: Sun Jan 17, 2010 12:01 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby Vincent Burel » Mon Jun 24, 2019 7:18 am

lzygmr wrote:The internal latency in VBCABLE_ControlPanel appears only to go up to 7168 smp, not 16K as you mentioned.


Your game is not playing back in the VB-CABLE but in the first Voicemeeter virtual input (these are different virtual audio device). Please run the VBCABLE_ControlPanel related to this Virtual I/O. This program is located in Voicemeeter folder (in your start menu or in your program files folder).

REM: Don't set the internal latency below 7168 samples on VB-CABLE.

lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Mon Jun 24, 2019 1:27 pm

I was able to locate and change the correct control panel to a max latency of 16384, restarted the computer and programs, yet still the issue remains of the game audio cutting in and out. Among the testing I found a solution that is still inconvenient being the following;

1. Game loads up and is not being read correctly by VoiceMeeter
2. Right click on the speaker with audio symbol (bottom right on PC), click on 'Sounds'
3. Click on 'Playback'
4. Scroll to VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)
5. Right click on VoiceMeeter Input, click on 'Properties' then click on 'Advanced' tab
6. Change Default Format to/from 24 bit, 44100 Hz (Studio Quality) / 24 bit, 44800 Hz (Studio Quality)
7. Click on 'Menu' in Voicemeeter and Restart Audio Engine

That process allows for the game to show up on the correct channel, in my case being 'Game Audio' and remains working throughout all cut scenes. I'm unsure exactly why this must happen for the audio to work correctly however still a burden to have to configure each time I open up a game which requires me to do so, along with the same game itself. If closed out and re-opened, I need to repeat the process.

Is there a better solution or a fix to this?

hdpcshow
Posts: 8
Joined: Thu Nov 01, 2018 6:19 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby hdpcshow » Thu Jul 04, 2019 6:09 pm

lzygmr wrote:I was able to locate and change the correct control panel to a max latency of 16384, restarted the computer and programs, yet still the issue remains of the game audio cutting in and out. Among the testing I found a solution that is still inconvenient being the following;

1. Game loads up and is not being read correctly by VoiceMeeter
2. Right click on the speaker with audio symbol (bottom right on PC), click on 'Sounds'
3. Click on 'Playback'
4. Scroll to VoiceMeeter Input (VB-Audio VoiceMeeter VAIO)
5. Right click on VoiceMeeter Input, click on 'Properties' then click on 'Advanced' tab
6. Change Default Format to/from 24 bit, 44100 Hz (Studio Quality) / 24 bit, 44800 Hz (Studio Quality)
7. Click on 'Menu' in Voicemeeter and Restart Audio Engine

That process allows for the game to show up on the correct channel, in my case being 'Game Audio' and remains working throughout all cut scenes. I'm unsure exactly why this must happen for the audio to work correctly however still a burden to have to configure each time I open up a game which requires me to do so, along with the same game itself. If closed out and re-opened, I need to repeat the process.

Is there a better solution or a fix to this?


Idk if its the same thing as i have but try this as a temporary solution.

1. Launch the game
2. Go to windows 10 sound options
3. Click "App volume and device preferences"
4. Select a different audio driver and then select the one you where using.
5. Now It should work.

lzygmr
Posts: 7
Joined: Wed Jun 12, 2019 1:13 pm

Re: Game Audio Stops Being Read By Voicemeeter

Postby lzygmr » Thu Jul 18, 2019 8:07 am

I appreciate the suggestion however that process unfortunately did not work for me, everything remaining as it initially was. The only process that works I know of so far is still the one I mentioned last.

Vincent will some sort of update or fix be implemented towards this?


Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 3 guests