Unable to set Input to WDM or MME

The Virtual Audio Mixer discussions and support...
Posts: 2
Joined: Wed Oct 16, 2019 6:23 pm

Unable to set Input to WDM or MME

Postby revose » Thu Oct 17, 2019 5:31 pm

Hey guys,
i have used Voicemeeter (Banana) and VirtualCable A and B for quite some time now and it always worked very well!
Now tuesday i had to setup my Win10 new.
I installed Voicemeeter and Cable A and B and it worked as expected with A and B being WDM input for Teamspeak sound and Media (Spotify and Browser) sound.
I also have my NT1 with a Focusrite Scarlett 2i2 3rd as Mic input and as main Output (all WDM).
This setup worked before the new installation of Windows and for one day after the new installation.

Yesterday i booted my PC and noticed no Sound on Cable A (Spotify). I switched from WDM to KS and i had sound. I switch back to WDM and sound was gone again and in settings it says for Input 1: "Failed to Open Input Device: pAudioClient: Initialize return error -2147024891 (0x80070005)". I also have this error for Cable B and Mic input. So all WDM inputs.
For MME Inputs i get the error "Failed to Open Input Device: Function waveInOpen failed. Undefined external error."

My output works fine with WDM although just with Buffering set to 1024 (there are distorsion sounds below 1024... :S). Never had this before.
I tried resetting settings and uninstall, reboot, install, reboot of VM and Cables. Nothing fixed my problem. I also checked the audio devices for naming and settings.

Also no new software was installed and no settings were changed from the day it worked to the day it didnt.

I have found similar problems in the forum* but there was never a solution to it.

Help would be greatly appriciated
I would have added a screenshot of the settings but apparently 1mb is to large..

Best regards


Posts: 2
Joined: Wed Oct 16, 2019 6:23 pm

Re: Unable to set Input to WDM or MME

Postby revose » Fri Oct 18, 2019 5:57 pm


I tried everything including "Voicemeeter or Audio problem after WIN10 update" guide. Nothing fixed it for me. WDM and MME inputs are still not usable. :cry:

Posts: 32
Joined: Wed Aug 02, 2017 5:54 pm

Re: Unable to set Input to WDM or MME

Postby Gwydion » Sun Oct 20, 2019 2:10 pm

Only thing I can think of is to try to update your audio drivers? See if that helps?

Posts: 30
Joined: Fri Nov 25, 2016 10:25 pm

Re: Unable to set Input to WDM or MME

Postby zapoqx » Thu Oct 24, 2019 7:00 pm

I'll go out on a limb here for this kind of issue.
Since you started from scratch (based on the setup Windows 10 new comment), lets go over a few things:
  1. You have installed the sound drivers either from manufacture/OEM (i.e. Gigabyte, HP, etc) or sound maker's site (i.e. Realtek)
  2. Your sound settings are setup correctly (i.e. You don't have the format set to something that could crash)
  3. You never changed the initial settings in Voicemeeter outside of A1 and inputs that you wanted (i.e. no Engine Mode changes and what not)

If all 3 is true, then the "wild shot" idea if you will will be as follows:

  1. Make sure A1 has the most stable sound driver (i.e. Onboard, not detachable)
  2. If 1 is true, then try going into the Sound Control Panel and go to the hardware in question and uncheck "Give Exclusive mode applications priority" just to test

Hope it helps!

Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 11 guests