Page 1 of 1

Realtek

Posted: Sun Jan 19, 2020 8:09 pm
by Abnormaalz
Just downloaded VM Banana and I've run into an issue. I use Realtek driver and I've got it set up that my rear output goes to my amplifier and my speakers and the front output goes to my earphones. Whenever I output my default audio device to my earphones, for some reason the microphone picks this up, and thus what is supposed to go to my earphones comes back on the microphone line too. And no, this isn't echo, because the sound is really mute in real life and pretty loud when I record it and play it back.

I've attached a link to a photo of my situation. I tried using different earphones, I've tried using headphones (which don't require a splitter, in case that would've been the culprit) but all yields the same result. What do now?
https://prnt.sc/qpwtst

Re: Realtek

Posted: Thu Jan 23, 2020 9:05 am
by Vincent Burel
according your picture:
1- you MIC is going nowhere (i mean you cannot hear or record your MIC) because assigned to no bus.
2- your 2 virtual input are routed to BUS A2 = Realtek 2nd output.
3- Nothing is routed to yoru main speakers (A1).

is it what you wanted ?

Re: Realtek

Posted: Sun Jan 26, 2020 9:15 pm
by Abnormaalz
Indeed, my mic is routed nowhere. I just have the VoiceMeeter Recorder listen to it. My virtual inputs are both routed to A2, my earphones, which are plugged in on the front of my PC in the green port. My earphones have a mic in it, which I put in the pink port, using a splitter. However, anything I play on A2, the green port in the front, somehow gets picked up by the pink port.