Page 1 of 1

Audio hitch when using multiple hardware outputs

Posted: Fri Feb 28, 2020 2:25 pm
by bigolslabomeat
Example: (you can hear it around the 2s mark)

This hitch happens frequently, between every 30s to a minute and it more pronounced/noticeable with "bassy" sound but is still very noticeable with speech. Doesn't matter what application is generating the sound, it will always happen.

To reproduce on my system I need my ASIO device in A1 and then Realtek in A2. If I have either of them in A1 (and nothing in A2) then there is no hitch, or if I send windows audio direct to each device there is also no hitch. It only occurs when I have both A1 and A2 active. I can work around by switching devices as I need them (I usually only use one at a time) but it's not ideal.

I am currently running but have tested the issue back to and it is still there.

Things I have checked/tried:
* All devices (in and out) are set to 24bit/48Khz.
* UMC202HD driver is updated to latest.
* Adjusting ASIO buffer size
* Identifying potential DPC spikes
* Removal/Reinstall of VM, CABLE and audio drivers
* Running with/without Ableton

Behringer UMC202HD 192k Revision v1.12 (Driver v4.59.0)
Realtek High Definition Audio (Audio Driver Version


Is there anything else I can provide to help debug?

Any assistance or recommendations will be greatly appreciated.

Re: Audio hitch when using multiple hardware outputs

Posted: Fri Feb 28, 2020 7:40 pm
by Vincent Burel
such "tic" in the sound can be corrected by finding a better audio configuration
for example by increasing your ASIO buffer to 512 instead of 256

did you follow recommendations there?

Re: Audio hitch when using multiple hardware outputs

Posted: Sat Feb 29, 2020 5:12 pm
by bigolslabomeat
Hi VIncent,

Thank you for the reply, but as mentioned above, I have tried various ASIO sample sizes and the problem is still the same.

I have followed your guides and a huge amount of other things for debugging audio issues in windows in general. This is only a problem in Voicemeeter and only when using multiple audio output devices.

Re: Audio hitch when using multiple hardware outputs

Posted: Tue Mar 03, 2020 10:11 am
by Vincent Burel
you may consider UMIC ASIO Driver is not working and select another audio interface (WDM, MME...) or another device as output A1

It happen sometimes that a USB device never work (it happens to me with a cheap USB MIC on a computer... but working fine on another computer)... then you can try to
1- unplug the device
2- reboot
3- plug it to another USB port and wait windows install all drivers for it
4- reboot
5- test it with MME or WDM interface before testing it with ASIO driver.

if it does not work, repeat the operation with another USB port.

Re: Audio hitch when using multiple hardware outputs

Posted: Sat Mar 07, 2020 2:51 pm
by bigolslabomeat
HI Vincent,

I am not sure if you have understood what the issue is here, let me try to break it down a little:

* If I send windows audio DIRECT to either device, there is *no* hitch
* If I have ONE device selected in Voicemeeter there is *no* hitch
* If I have TWO devices selected in Voicemeeter there *is* a hitch.

The drivers are clearly working OK when they are operated outside of Voicemeeter or when they are the sole device Voicemeeter is using.

The UMC driver is not a "cheap USB mic" but a Behringer UMC202HD, a device I bought *specifically* because your guides say to have a strong ASIO device as A1, so even if switching to WDM/MME had worked, that would go against all your previous advice on optimal running of Voicmeeter.

Also as stated in OP, I have done all the things you have suggested.

As this has not always been an issue (I've been running this setup for over a year) I see this a a bug in VM, possibly triggered by changes in Windows updates) and am trying to report it and get you all the information you might need to fix it.

Re: Audio hitch when using multiple hardware outputs

Posted: Sun Mar 08, 2020 9:03 am
by Vincent Burel
try this: set "input exclusive" mode to NO

Re: Audio hitch when using multiple hardware outputs

Posted: Mon Mar 09, 2020 7:19 pm
by bigolslabomeat
Hi Vincent,

That didn't help I'm afraid.

I also tried manually forcing ASIO/MME/WDM to use the same sample buffer size but the issue still occurs.

I'm convinced it's something in a Windows update, I'm on 1909 and it was also an issue in the last version (17xx) but wasn't some time ago. But I checked for DPC spikes as that seems to be the most common audio issue in recent Windows versions and there was nothing either at the same time as the hitches or particularly high.

Is there some internal timing in Windows or Voicemeeter that is getting confused when using two audio drivers at the same time? Can the drivers somehow go out of sync and then catch up with each other?

Re: Audio hitch when using multiple hardware outputs

Posted: Mon Mar 09, 2020 8:08 pm
by Vincent Burel
we already had some cases of Windows installation not working at all with audio driver... just had to re-install everything from scratch...

With WIN10 we may have cases where the audio stack is in mess after an update or bad audio driver installation and it stays like this until you find the right audio driver to re-install...

but we do not recommend anyway to use exotic options in Voicemeeter System settings while you have stability problem.