Page 1 of 2

Stuttering Problem(again) - Tried everything (turns out NOT everything)

Posted: Sun Jan 26, 2020 6:00 pm
by SailCat
Case Reopened.
After a whole 2 days of no issues, today I booted up to find the problem is back.
It's even WORSE than before as it won't go away, even when restarting the VB Audio Engine...
Yesterday, same settings, everything was working fine.
Today, none of the Audio cables give a clear signal..

I'm losing my mind. The signal is fine when it comes out of the VAIO, AUX or VAIO 3.
But as soon as I run it through an VAC it's stuttering and completely broken.
Mic same story.


Several Hours in now and no more stuttering.
A bump from 512 to 640 on the WDM Buffering was all that was necessary to get perfect performance as well.
At 640 I'm also not worried about the lag/delay.

Thanks Vincent for your initial response and intention to help. I'm sure you're very busy so I do appreciate it :)
Hope my logging my progress here will help others.



I found a solution. Although I'd rather have had everything working normally like before. I did find a way to solve my stuttering.
After the 10000th clean reinstall with 10 reboots... I realized I hadn't tried bumping the WDM Buffer (which tbh is often offered as a possible solution to these kind of issues, on this forum) so that's what I did.....

Guess what... no stuttering for over 4 hours now.
I bumped it from default 512 to 1024 and will now experiment with lower buffers.

Hi Vincent (and Forum)

As an avid Voicemeeter Potato user (for my stream) I wouldn't know where to go without your amazing software.
However I've run into a problem I can't seem to solve.

Over Christmas I flashed my mobo bios and accidently deleted my Raid array. I had to reinstall my complete PC.
Windows 10 pro, everything.

So I also reinstalled voicemeeter potato and all the virtual audio cables (ABCD + the standard one)
Since then I have a problem I cannot solve. I've followed all your guides on installation and de-installation several times.

The situation is as follows:

There is stuttering.
1. My microphone starts to stutter every 15 to 20 minutes.
2. My Music Monitor (will explain) begins to stutter also every 15 to 20 minutes.

Both issues are fixed with an Audio Engine Restart. But Will always return after a short while.

The setup is as follows:
Realteak Audio USB Microphone -> A3 Cable Input (VB-audio cable)
So my Default input Device is set to Cable-Output (VB-Audio cable)

Spotify/Music apps - Voicemeeter VAIO3 Input -> A5 Cable-D Input (VB-Audio Cable D)
So I loop Spotify back into Voicemeeter to create a Monitor, which I can then control separately.
This is to separate my Music output to Streamlabs from what I hear myself.
This worked great before the reinstall.

I've added in a Screenshot:

Do you have any idea what I can do to stop the stuttering from returning all the time?
The most important is the problem with my mic, because it effects my stream.

I've tested and for both stuttering issues the stutter occurs behind the Virtual Audio Cable. The signal is perfect fine before it goes through the VB-Audiocable / VB-audio cable D) so clearly the audio cable is somehow having an problem causing the stutter/distortion.

However no amount of clean removals/uninstalls and reinstalls seems to fix it. Nor can I find a setting to fix it (I tried the exclusivity control)

please give me your insights.

Re: Stuttering Problem - Tried everything :(

Posted: Mon Jan 27, 2020 3:09 pm
by Vincent Burel
could you post a full resolution picture of Voicemeeter and its system settings dialog box please.

Re: Stuttering Problem - Tried everything :(

Posted: Mon Jan 27, 2020 11:21 pm
by SailCat

If you rightclick this image and open the image in a tab you get a bigger full resolution version.


Re: Stuttering Problem - Tried everything :(

Posted: Fri Jan 31, 2020 7:57 pm
by SailCat
I found another issue.

When I output to - Speakers (Arctis Pro Wireless)
It actually goes into my Cable-A Input rather than to the Speakers.

Something is really going wrong since the reinstall of Windows 10 and it's making it impossible for me to adequately use Potato and the VAC for my stream :( any



ok I fixed this issue (the last one so not the original stuttering) by turning off the forced output device in windows:

Image ideas would be super welcome from anyone.

Re: Stuttering Problem - Tried everything :(

Posted: Sat Feb 01, 2020 1:15 pm
by SailCat
I'm wondering @vincent.
Could it have to do with my Realtek Audio Drivers?

I have an MSI MPG X570 GAMING PRO CARBON motherboard.
With an ALC 1220 Audio Processor.

Although that doesn't matter, I did get newer drivers & NAHIMIC 3 in December for it when I reinstalled my system. Could this be a compatibility problem?

Re: Stuttering Problem - Tried everything :(

Posted: Sun Feb 02, 2020 10:40 pm
by SailCat
Problem solved.
See openining post.
This thread can be closed. Thanks.

Re: [Solved] Stuttering Problem - Tried everything (turns out NOT everything)

Posted: Mon Feb 03, 2020 2:47 pm
by Vincent Burel
you may check if all your driver are well installed with the right icon and pin name.
if not it usually means that WIN10 update brought a mess in audio stack:

Re: Stuttering Problem(again) - Tried everything (turns out NOT everything)

Posted: Tue Feb 04, 2020 12:03 pm
by SailCat
Thanks Vincent.
Will do. yesterday everything worked.
Today everything is broken again.

When installing, what order do you advice

Windows Audio Drivers -> Potato -> VAC's
WAD -> VAC's -> Potato


Re: Stuttering Problem(again) - Tried everything (turns out NOT everything)

Posted: Tue Feb 04, 2020 8:06 pm
by Vincent Burel
whatever order, but
- check that they are totally de-installed (no presence in the windows device manager) and REBOOT before restarting to install again.
- REBOOT after each installation.

Re: Stuttering Problem(again) - Tried everything (turns out NOT everything)

Posted: Thu Feb 06, 2020 12:33 pm
by SailCat
Ok. I'm getting desperate now :(

I've done everything as you outlined as far as I can tell. I read all the posts on this forum regarding installation and removal.
I've followed those instructions to the letter.

1 by 1 each VAC and after that potato.
after each removal I restarted the PC.

1 by 1 starting with Potato and then each VAC.
Rebooted after each install...

nothing is fixing this. The stuttering perseveres.
Sometimes it's gone for a few hours, but it always returns after I shut down the PC or whenever I change something in the audio settings (like turning on Dolby Atmos)

The only way now to remove the stutter for a while is to reselect the input on Potato.
Example: Microphone starts stuttering. I reselect the 'Realteak Audio USB Mic' as the Input device, which will remove stuttering temporarily.

However when I do that it usually starts stuttering on my Spotify monitor (meaning the Cable-D VAC which loops Spotify back into Potato after it comes out VAIO3)

So then I need to reselect Cable-D VAC as well.

The only thing I am certain off is that the VAC's are not working properly and the problem sits with them somehow.
apart from that I cannot find a way to solve it.

I've tried changing the buffers, reinstalltions, changing the Frequency settings on everything from 48hz to 44hz..
Nothing helps.