Page 1 of 1

VBAN errors randomly

Posted: Sat Jun 29, 2019 3:10 am
by cattywampus

I use 2 computers while streaming. I use the 2nd PC for music and send it over VBAN to my gaming/streaming PC. I also send Chrome audio.

I am having trouble with random errors that result in audio having small blips and stutters. The errors usually show as missing or underun. Sometimes it will start straight away, sometimes it will start over time. It just seems random and what I am doing when it happens vs. when it's not happening doesn't change.

I run 1gbit wired network, the PC's are both more than powerful, I am not taxing the network - only I am using the network. Using the "restart audio engine" option in VM does nothing. Rebooting the PC's is the only thing that really works, but that isn't really an option mid stream.

I read a post from over a year ago about errors creeping in over time. Is this still the case?

I have attached some screenshots of the settings for both computers. I have tried different settings. I have tried the different network speed settings and all that. They all seem to start exhibiting errors at some point


Re: VBAN errors randomly

Posted: Thu Jul 04, 2019 7:05 pm
by cattywampus
Any assistance would be greatful.

VBAN is becoming unusable for me unfortunately.

Re: VBAN errors randomly

Posted: Fri Jul 05, 2019 3:33 pm
by Vincent Burel
assuming your voicemeeter are working correct on both PC
it means the main stream is running ok (when you playback sound with the integraetd player for example).

you may have a network configuration problem. for example you have 2 network adapter cnofigured in the same address range.

anyway, if you want more help, you may post screenshot of your voicemeeter VBAN dialgo box at least and explain where is located the problem.

Re: VBAN errors randomly

Posted: Fri Jul 05, 2019 7:09 pm
by cattywampus
I posted an Imgur link in my original post with screenshots of the VM settings on both computers. I will post them as attachments though.

The IP/Subnets are / and subnets of for both machines.

I tried setting both sides "net quality" to medium last night, and for 8 hour, I had virtually zero errors. Today I have booted the computers up to stream again and it is throwing a lot of errors again, even though nothing has changed.

The file sizes that are allowed to upload attachments to this forum are crazy small by the way. Is the reason I uploaded to Imgur instead - not even sure whether you'll be able to read any of the text that is on the attachments the quality has to be set so low.


I seem to be able to reboot both computers and then it goes on to work ok...I THINK. This is not 100% confirmed. But it's a pain in the backside cause when I reboot, I then have to start getting everything set up again - and I will spend sometime before streaming doing other stuff. Having to reboot is a hindrance to my work flow.

If it works for 7+ hours without a problem, one surely can assume that there is something specific that is causing it to start throwing errors when everything else is set the same as when it worked flawlessly.

I would really like to find an answer to this as the VBAN is super useful and has improved my streaming setup immensely. The hassle makes it hard to love though. Am more than happy to test things in order to get the bottom of the problem.


Re: VBAN errors randomly

Posted: Mon Jul 08, 2019 10:34 am
by Vincent Burel
ok, so the problem is maybe not coming from VBAN but one of your voicemeeter running unstable...

if it happens again, check that your Voicemeeter output A1 is running correct
(for example by playing an audio file with the integrated recorder).

if the Voicemeeter main stream (output A1) becomes unstable, all other stream will become unstable so you may follow recommendations there:

however the 4th RED LED means "missing frame" , meaning the network lost packet... so maybe the problem is more on the network.
(2nd to 4th RED LED are usually error due to network - while 1st and last LED can also be due to audio stream stability).

LED 1: overload (VBAN stream early clock error)
LED 2: corrupt (very unusual)
LED 3: order (very unusual)
LED 4: missing (problem on network)
LED 5: underrun (VBAN stream late clock error)

Re: VBAN errors randomly

Posted: Mon Jul 29, 2019 3:28 pm
by cattywampus

I just wanted to feedback what I think I have realised what is going on. I am very aware that as soon as I post this, it will be a "spoke to soon" moment and everything will go tits up again!


After learning that everything with VM is tied to the functioning of A1, I paid more attention to the status of that and the Windows device it pointed to... my Sound Blaster Z. I was finding that for whatever reason, even though I set the sample rate/format to 16bit 44100hz, it would random go back to the default it seems to prefer being at, 24bit 48000hz.

I *think* so long as I ensure that all devices on both computers are set at 16bit 44.1, it all seems to be working reasonably well.

I always thought that I had been keeping on top of making sure all devices were set correctly, but there is a chance that the times it started throwing errors one device maybe switched to something else and that is what may have been causing it.

Regardless, for the last week or 2 things have been pretty much perfect. I was on the verge of ditching VBAN and shelling out for way to transfer audio streams from one PC to another using a hardware solution - but I am feeling more confident that VBAN is actually viable.

I really hope that I won't be coming back to this thread and that the problems are resolved!