VBAN Receptor not receiving packets on certain models of iPhone

VB-Audio Network Protocol and applications
Sonicity
Posts: 5
Joined: Thu Nov 08, 2018 8:31 am

VBAN Receptor not receiving packets on certain models of iPhone

Postby Sonicity » Tue Nov 27, 2018 8:13 am

I installed the app on 2 iPhones. The first iPhone successfully connects to my PC, the second one does not show RCV indicator. I pinged from both side and made sure the network is reachable. (Sometimes iPhone does not respond to ARP packets which can be fixed by a bidirectional ping.) However the RCV indicator still didn't light up.

I realized that the second iPhone is a China market model. Due to enormous customer complaints, Apple now requires the user to explicitly grant network permissions for both Wi-Fi and cellular on China models, at the time when the app first tries to connect to the Internet. Since VBAN only passively listens on a UDP socket, and never actively connects, iOS didn't pop up a window for me to grant that permission, making VBAN Receptor totally unusable on that machine.

The solution might be simple: try to initiate any connection when the app starts. I don't know whether a low-level connect() would work, but preferably an HTTP request or a DNS request would work. I searched over Apple's development documents but found nothing useful, I will update this post when I have more idea.

Version: VBAN Receptor Lite 1.2

Thank you!

Vincent Burel
Site Admin
Posts: 661
Joined: Sun Jan 17, 2010 12:01 pm

Re: VBAN Receptor not receiving packets on certain models of iPhone

Postby Vincent Burel » Sun Dec 02, 2018 4:42 pm

thanks for this interesting feedback!

We also noted some strange behavior with iOS devices, according WIFI AP configuration
- if it is connceted to internet or not
- if the connection is protected by a password (WEP) or not.

you may try the VBAN SPOT application , which send a ping first , before sending the VBAN Stream...
a Ping or ARP request could also be the solution...


Return to “VBAN Procotol”

Who is online

Users browsing this forum: No registered users and 0 guests