Sound not splitting properly with VAC

VB-Cable A & B, HIFI-Cable, ASIO Bridge
Booyaah
Posts: 2
Joined: Thu Dec 21, 2017 12:05 am

Sound not splitting properly with VAC

Postby Booyaah » Thu Nov 15, 2018 8:11 am

Hi,

So I think I have a typical situation, where I want to record video from a game, while simultaneously playing music from Winamp, and voice comms going through discord. I want to hear sounds from all 3 sources, but I only want to pick up the audio from the game in my recorded video. So I setup the following:

1) Game - running on default speakers
2) Winamp - output to VAC Cable A
3) Discord - output to VAC Cable B
4) Shadowplay - doing the recording

In my Cable A/B Sound properties I have 'Listen to the device' checked. So as I'm playing my game I can hear the audio from all 3 sources. However after I record a video in Shadowplay and then watch the video, I am still hearing the sounds from all the devices in the recorded video. I thought maybe this was a Shadowplay issue, so I switched to MSI Afterburner video recording, but still have the same issue. Do I need some additional kind of software?

phelagor
Posts: 2
Joined: Tue Nov 20, 2018 8:16 am

Re: Sound not splitting properly with VAC

Postby phelagor » Wed Nov 21, 2018 7:41 am

Hey,
have you solved your problem?

In case you haven't I might help you.
Since you haven't provided any screenshots or closer information to your audio setup, I just assume the following.

You are only using VB-Cables (Not Voicemeeter / Voicemeeter Banana)
You are Routing the Audio of the VB-Cables to your default Playback device? (checked the box "Listen to this device" in the following screenshot)
ListenDevice.png
ListenDevice.png (40.89 KiB) Viewed 120 times


So you can hear every audio source at your default Playback device (your Speakers).
But that also means that every program that captures the audio from the default device, now captures your other audio sources (like winamp or discord).

You might try using One of your VB-Cables as default Playback device, which would be your game sound, and tell Discord and Winamp to either use your second VB-Cable or install a third one (the standalone, not A+B one).
Now use the "Listen to this device" option from Windows for all your VB-Cables, but choose your Soundcard Output at "Playback through this device". Since your default Playback device is now one of the VB-Cables, your recording Program should pick the Audiostream from this one, but you should still be able to hear every Audio Source via your Speaker.

You might also have a look at Voicemeeter Banana, which gives you even more controll over the Routing and individual Audio Levels.

Booyaah
Posts: 2
Joined: Thu Dec 21, 2017 12:05 am

Re: Sound not splitting properly with VAC

Postby Booyaah » Thu Dec 06, 2018 1:02 am

Setting my default playback device to the default VA cable and checking listen to device fixed it. I can hear everything but only game sounds get recorded, no music or comms.

Thanks!

p.s. If I wanted to record all 3 audio streams as separate files, could I do that with Voicemeter?


Return to “VB-CABLE, The Virtual Audio Cable”

Who is online

Users browsing this forum: No registered users and 1 guest