Trouble with WDM Realtek digital output

The Virtual Audio Mixer discussions and support...
DruiD
Posts: 7
Joined: Thu Jan 24, 2019 5:28 am

Re: Trouble with WDM Realtek digital output

Postby DruiD » Mon Jan 28, 2019 4:18 pm

user4711 wrote:The important thing is that buffer size must be 256 or 512 or 1024.


WDM Default in VM is 512... so leaving at that...
user4711 wrote:And you need in windows sound prefs enable exclusive mode and both option in the exclusive area need enable in realtek spdif output. maybe you need reboot, because another program that use sound forbid that WDM switch to exclusive mode.


A bit clearer here please, do you mean ALL your output devices to be configured as exclusive (only), or just A1 (as VM bases of A1), or just the virtual VM input that you set as default sound etc.?? I have 5 output devices, only 1 of them is SPDIF\Optical out (my amp \ gaming headset), rest of the A2-A5 outputs are either analog or USB.

In VM system settings\options
All outputs are showing as correctly open, up to 8 channels, 48khz and except for the RIFT and USB interfaces, are driven by Realtek drivers.

ExK_Gaming
Posts: 1
Joined: Fri Feb 01, 2019 7:45 am

Re: Trouble with WDM Realtek digital output

Postby ExK_Gaming » Fri Feb 01, 2019 3:40 pm

'reviolent' said that uninstalling the "realtek"
application from (control panel > uninstall programs) solves the issue and I can confirm. I just did this and it works to the point that I now have a 512 buffer size with 48000Hz and crystal clear audio that is higher fidelity than normal stereo. I can not tell the difference between the audio I am getting now than using just the realtek driver as the default playback to work around the issue before.

I then used ASUS GRID to reinstall the latest REALTEK driver and it continued to work for a couple minutes but reverted back to the issue itself. Uninstalled the driver/application again and presto! Problem goes away. The only issue is that for things like Dolby Atmos, it wouldn’t/couldn’t recognize any audio devices without having the driver installed.

The short; REALTEK DRIVER seems to be the issue. Whether it’s a communication issue between VMB and Realtek I couldn’t say. Just my .02.

DruiD
Posts: 7
Joined: Thu Jan 24, 2019 5:28 am

Re: Trouble with WDM Realtek digital output

Postby DruiD » Sun Feb 03, 2019 11:33 am

Very interested in these "hacked" realtek drivers that a) seem to work b) provide dolby live and DTS Etc.

bidomo
Posts: 4
Joined: Wed Sep 21, 2016 3:50 pm

Re: Trouble with WDM Realtek digital output

Postby bidomo » Sat May 02, 2020 5:25 pm

I had the same problem, have some Realtek ALC audio chip, it doesn't matter which Realtek audio driver I used, the buffer was too high or audio got choppy, uninstalling and using the regular High definition Audio codec from Microsoft used to solve it.

Well I installed a brand new SSD Drive and went the clean install way, turns out, that changing audio settings to match same Sample rate, my audio went nutz, totally distorted, with microsoft driver that is, so I installed an alternative driver (not sure if allowed to discuss modded drivers), and the problem disappeared for a while, then shut down PC, came back to use it, problem was there again.

I have to say that the hard stuck 1056 SR was a constant, but it seems to be related to the shared mode, I was tinkering with all my output devices (non realtek), the buffer was the same.

Started playing with the Virtual IO control panel, got no sound as the buffer was too low, started setting it manually till it worked, then I set all output devices to exclusive mode, and when switched devices, the buffer got fixed immediately, even using the modded driver.

So my Recommendations are:

[*] If you want to use Virtual cables in shared mode, that's ok, but your output devices must stay exclusive mode
[*] If you need low latency audio, follow the above advice and set the buffer as low as possible but keep an eye on Virtual IO to see if you need to pump up the buffer
[*] If you just need the audio to not be choppy, you need shared mode on output devices, and don't care that much about a bit of latency, open the Virtual IO control panel corresponding to your preferred output device on windows, click latency, and set current latency to match whatever VoiceMeeter says its set to, choppiness will go away

Remember guys, Exclusive mode is the key, even with Realtek drivers installed.

Will continue to try playing with settings, if I get no new discoveries, don't expect an update, if I do discover anything new, will report back


Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 9 guests