Voicemeeter Banana adding a constant hiss to my recordings which is absent when recording direct from the mic

The Virtual Audio Mixer discussions and support...
Post Reply
Sergeant Smoothie
Posts: 1
Joined: Mon Jun 07, 2021 10:43 pm

Voicemeeter Banana adding a constant hiss to my recordings which is absent when recording direct from the mic

Post by Sergeant Smoothie »

Okay my intent with Voicemeeter, like many, is to use it to split up audio for recording Let's Plays on YouTube and eventually streaming on Twitch.

My PC is due to be updated (it's nearly 10 years old now), and the quieter case I get should alleviate much of my background noise.
I've added my setup at the bottom of the post

I've uploaded a video of the problem here: https://www.youtube.com/watch?v=j_5P2jHqM1U

It's a recording in Audacity with the recording input set to"Blue Yeti X" (thus bypassing Voicemeeter), then another recording in Audacity routing the mic through Voicemeeter Banana.

As can be heard: the second recording introduces lots of hiss to the mix.
I tried changing the Master Section's "modes" on the two blue option on the left from "Stereo Repeat" to normal mode but it only marginally improves the hiss, if at all.


My other issue is that I constantly forget how Voicemeeter actually works. The terminology for input and output often confuses me because I forget what counts as an output and what counts as an input. I've included a diagram of how I *think* my Voicemeeter works below, though I'm unsure about the blue bit I've highlighted:


The diagram shows my VM setup quite succinctly, as well.

I've also linked below a screenshot of my VM "blank", so if my diagram is wrong, you cna take that picture and show the actual routing with a clean slate:


Thanks for reading!


My Setup:

Blue Yeti X mic on a generic stand clamped to the back of my computer desk, with a 3m long generic micro USB cable I bought off Amazon
Gaming headset plugged into the Mic's aux output. PC sond ruted thru headset using Voicemeeter Banana.
1x 27" 1440p, 144Hz ASUS TUF monitor, 1x 24" 1080p, 120Hz ASUS TUF monitor
Wireless 2.4GHz keyboard & mouse

PC (built in 2011):
Antec 300 case with 1x 140mm & 1x 120mm fan
Intel Core i5 2500k processor @3.3GHz overclocked to 4.4GHz, with a huge CPU cooler and 2x 120mm fans strapped to the side
NVidia GeForce GTX1060 3GB graphics card
12GB DDR3 RAM at 1333MHz
Some 500W Corsair PSU from 2011
MSi P67A-C45 motherboard (LGA1155)
1 512GB SSD, 1 1TB HDD, 1 optical drive, 1 wifi card

Thanks for any and all help, it is much appreciated, as is this program which is kind of magical sorcery to me.
Posts: 159
Joined: Tue Feb 18, 2020 12:04 am

Re: Voicemeeter Banana adding a constant hiss to my recordings which is absent when recording direct from the mic

Post by xcasxcursex »

Hi Sarg, I had a listen to your recording. What I'm hearing there is the normal background noise and sound card noisefloor, which is present in both recordings, then amplified (with the rest of the signal) for the second part. The hiss is actually there always.

What I do wonder though,is where this amplification is occurring. One of your images shows a boost on the mic so that might be it, but one shows a cut so that wouldn't be it. Otherwise, there's an EQ effect on the output, but that's it. It's generally accepted that one should cut and not boost EQ. Kinda. This is audio engineer voodoo, I'll let you form your own style based on the wisdom of the interwebs: https://duckduckgo.com/?t=ffab&q=EQ+cut+don't+boost

But yeh the punchline here is that the hiss is actually always there and it's being boosted when the mic is so it's becoming more apparent. You'll need to look into some noise reduction techniques for the mic input. Beyond the ngeneral ambient noise reduction you mentioned, It might be just using the EQ in VM, or perhaps a VST plugin like reafir (very popular among streamers for this purpose because it's a one-click job to tune it)

BTW, yes you're right the system sounds come in via the default sound card asset in windows settings, which is likely the one you have in blue.
And just leave the stereo settings at the default normal, that should be fine for your needs. That's for surround stuff.

You have a good radio voice mate I'm sure it'll stream well, good luck!
Post Reply