Surround Sound Logitech G635 USB

The Virtual Audio Mixer discussions and support...
AxeTheRipper
Posts: 7
Joined: Sat Sep 22, 2018 6:00 pm

Surround Sound Logitech G635 USB

Postby AxeTheRipper » Tue Sep 03, 2019 2:12 pm

Hello there I have a question just got my self logitech G635 Headphones and I am connecting them thru USB
Because they have option for surround sound now I have run in a problem surround sound only works with MME.
I will like to know is it possible some how make it to work with WDM because MME feel a bit of with quality.
I have try to set it to WDM but I can enable disable surround sound in G hub program but no efffect on sound but MME works.
Could some body help me out I hope I didn't waist again money on headphones :(

Vincent Burel
Site Admin
Posts: 1234
Joined: Sun Jan 17, 2010 12:01 pm

Re: Surround Sound Logitech G635 USB

Postby Vincent Burel » Fri Sep 06, 2019 8:30 am

it's a recurrent question with Logitech... it could be great to ask to them too...
maybe they could try Voicemeeter and just let us know why it does nto work with our WASAPI management.

AxeTheRipper
Posts: 7
Joined: Sat Sep 22, 2018 6:00 pm

Re: Surround Sound Logitech G635 USB

Postby AxeTheRipper » Tue Dec 10, 2019 5:15 pm

I could tell sorund sound is not working with WDM over any type of headphones
I tried razer man'o War headphones soround sound only work thru MME

Vincent Burel
Site Admin
Posts: 1234
Joined: Sun Jan 17, 2010 12:01 pm

Re: Surround Sound Logitech G635 USB

Postby Vincent Burel » Thu Dec 12, 2019 9:56 am

I guess the reason is because we are using WASAPI exclusive mode to connect output device, possibly bypassing software emulation...
seems the surround emulation is not located in the device or the driver, but in additional user module attached to Windows Mixer (bypassed by the WASAPI exclusive mode)... to be confirmed...

So the solution is to use MME interface.

Tychoid
Posts: 2
Joined: Tue Dec 17, 2019 5:42 am

Re: Surround Sound Logitech G635 USB

Postby Tychoid » Tue Feb 04, 2020 10:58 pm

Got the same problem (with the G935). Thanks for the extra info, Vincent.

MME isn't too terrible of a compromise, but it does add about half a second of latency to the audio output... even with voicemeeter latency tweaking.

Here are the best stable settings I can get without the audio engine crashing:
Image


Return to “Voicemeeter”

Who is online

Users browsing this forum: No registered users and 10 guests