Page 6 of 8

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Thu Jan 21, 2021 9:50 am
by topia
Vincent Burel wrote: Thu Jan 21, 2021 8:33 am Voicemeeter and VB-CABLE can work at 96kHz without problem.

so you recommend to follow recommendations there: viewtopic.php?f=6&t=451
and first validate your output A1 device as explained.

also you may watch this video about how to use an ASIO device correctly with Voicemeeter:
Thank you for your recommendation.

I followed that steps and ASIO configuration - but no luck.

check ASIO is working? -- Yes. Cubase 11 works correctly on this ASIO, with 192kHz/24bit and 96kHz/24bit.

I tried A1 only configuration with ASIO 96kHz buf 512. of course I set All VAIO default format to Stereo/96kHz/24bit.
  • seamless audio with foobar2000 and VoiceMeeter integrated player
  • some interrupts with iTunes (any iTunes configuration, includes DirectSound/96kHz/24bit)
And, I can confirm below while playing with VoiceMeeter integrated player:
  • no other audio playing: seamless
  • no other audio playing with scrolling iTunes library: almost seamless
  • with iTunes playing: a few short (10-20ms) interrupts occurred
  • with iTunes playing and scrolling library: many interrupts occurred
  • with foobar2000 playing: seamless
  • with foobar2000 playing and web browsing (Google Chrome) including heavy scroll: seamless
  • with foobar2000 playing and iTunes library browsing: many interrupts occurred

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Thu Jan 21, 2021 10:37 pm
by robertkjr3d
Itunes... does seem to be the worst offender.
A few posts ago, I was actually trying to defend it, and saying how you need to do this or that. But I'm also experiencing the same issues.

I notice within Foobar/Kodi. I do not experience the same issues as I do within Itunes. I"ve tried uninstalling and reinstalling.

So i have a 5.1 setup in two different rooms. 1 through analog speakers connects. 1 receiver through HDMI... It's been working that way for many years.
I've heard robotic/distorted sound before. But only because of using Equalizer APO. And when that software got mismatched because of a driver. All you had to do was. Turn off the configuration for Output(a1)... then turn it back on again.

Sometimes I wish I had that rocksolid machine back.
I've also heard some small pops and issues before. In the past... I had it my receiver setup WDM as A1. And the local speakers A2 MME. That worked, however I would sometimes get a 'POP' intermittently, once randomly every 20mins. Eventually I learned to switch the arrangement. Both WDM... A1) local speakers... a2) the receiver. No popping. Rocksolid...

But now: I have uninstalled 'Equalizer APO'. I have new and faster motherboard,cpu,graphics card,drives. I even bought a 'Sound-Blaster Z'.
When I first upgraded... The sound was great. But after the latest Windows-Updates with 20H2. I'm having many issues.
What's really great about the sound-blaster-z, is that beemforming microphone. Other than that, is the Soundblaster's outputs better than realtek on my Gigabyte motherboard? hardtosay... Probably not. There is also a digital-IN port. And I thought I was going to use it. The Soundblaster also has 'What U Hear', which I've investigated using as an alternative to Voicemeeter.

Vincent is always talking about 'ASIO' as being the best choice. But I haven't been able to crack using that. Not for lack of trying.

So I have tried these configurations:
Using my standard voicemeeter-banana as above... With WDM outputs. It just fails. Everything sounds robotic. I can set the MAX-Latency to the some of the highest numbers. Set the buffer to 2048... doesn't matter. Everything sounds like Davros (yes the creator of the Daleks).
So one solution is to switch to MME for all outputs. A1 and A2. This works Except for Itunes. But is that desired?
Also I can't go higher than 48000 samples... 24bit.

I've tried all of these:
A1 --- > Realtek (speakers) or A1 ----> Sound Blaster Z (Speakers)
A2 ----> AV Receiver

I've also tried:
A1 --> Av Receiver
A2 --->Realtek (speakers) or A2 ----> Sound Blaster Z (Speakers)

have I tried asio ... I've install a number of different ones.
one that I can't remember at the moment did not allow anything greater than 44.1 samples.
another, you couldn't pick more than one output.

So non-Voicemeeter approach:
my Soundblaster allows this:
1) set the SoundBlaster Z (speakers) as the main sound device....
2) go to recording in sound properties... right-click 'What U Hear' Change Advanced to '24bit 48000 6Channels' <-- highest it allows.
a) Then click on 'Listen to this device' --> output through 'AV Receiver'
But I still get some small popping in Itunes.... This method does not give me the kind-of control I like with voicemeeter though, like I can't see as easily what's going on with the rear-channels.
And GotoMeeting?! Not Zoom. I think Gotomeeting has trouble with multichannel audio. I've heard you might need to change your audio to 2-ch before a meeting.
Foobar sounds great!
Kodi sounds great!
Windows Media player sounds great!

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Fri Jan 22, 2021 6:06 am
by robertkjr3d
So as in my last elongated post...

I decided to give the ASIO options another try.
The FLEXASIO seems to be the ticket. It seems to have solved my problems. I'm not done testing as I have to sleep at some point.

So A1 --> FlexASIO
Config has...
backend = "Windows WASAPI"
device = "Speakers (Sound Blaster Z)"
channels = 6

Then A2 is WDM -- AV-Receiver.

I kept testing...
I was able to reduce Voicemeeter latency, buffering, jam the Sample-Rates up to 96K...
everything kept working! I kept checking the sound. But I'll keep testing.

EDIT: HOLD the phone...
The second device is still showing crackling. (at least with Itunes...) I might switch back to my realtek, instead of the soundblaster-z. See if that helps. The soundblaster sometimes does this thing where it throws the sound in different speakers, and I've turned the 'Surround-enhancement'--OFF but it still does it anyway.

I think I'm switching to 'Musicbee'...(for organization and layout) I'm tired of Itunes issues.

Latest config: I changed to Exclusive mode... I did switch to my Realtek.
backend = "Windows WASAPI"
device = "Microphone (Sound Blaster Z)"
device = "Speakers (Realtek(R) Audio)"
suggestedLatencySeconds = 0.05 # 50 ms
# Set the output to WASAPI Exclusive Mode.
wasapiExclusiveMode = true

Edit: Nope... Zoom is broken...too even when stating the microphone. Adding the mic only lasted about 5mins. then went back to distortion.
hmm I got it working again. By swapping the devices. now: [output] device = "3 - AV Receiver (AMD High Definition Audio Device)"
then a2 = realtek (speakers)... still testing. Zoom is working. musicbee is working.
Edit: Nope... that just switched where the crackling goes. Now the AV-Receiver crackles...

Edit: I've turned off FlexASIO and switched back to two WDM Outputs. For some reason at the moment my WDM outputs are working. Perhaps all this fumbling around with different items?

Edit: So why is it working now? I don't have a great conclusion.
I installed FlexASIO, I couldn't make it work in the end and I turned it off.
I installed a VB-Virtual-Audio Cable... But it found it not useful for me. It does not have the capability that 'What U Hear' does. However, is it possible that the 'VB-Virtual Audio Cable' corrected something? Even though I'm not using it.

So right now... I'm running A1-->WDM AV-Receiver and A2--> WDM (Speakers Realtek) @ 96,000hz... 24bit, 5.1CH... I hear no distortions... (Well except ITunes, but I've stopped using it. I switched to Musicbee.) I even flipped on the 'WDM Input Exclusive Mode'. I was able to reduce the 'Buffering' and 'Latency'....Still working.

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Thu Feb 04, 2021 5:29 pm
by Rexzone
good, for a week, the voicemeeter potato, the sound goes away and the application hangs, I don't know why it happens
my windows is up to date

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Fri Feb 05, 2021 3:42 pm
by Vincent Burel
you may follow recommendations there: viewtopic.php?f=6&t=451

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Mon Feb 08, 2021 6:25 pm
by Rexzone
Well, the challenge changed and he did not accept it, if I put regen, will it work for me?

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Thu Mar 18, 2021 12:49 pm
by RadekPilich
This is hell.

After WIN10 update, VM kept defaulting to 44k instead of 48k despite all the settings. So I reinstalled / updated drivers and now it seems that my Soundcraft USB Audio ASIO driver stopped being connectable to VM.

I went through dozens of uninstalls, reinstalls, reboots, power offs today and it is still the same.

Everything works correctly, only VM keeps flashing and not accepting the device.

What the hell should I do?

What exactly does this first step mean?

1- Remove all USB audio device + REBOOT.

Do I have to disconnect them or uninstall as well? Do I also need to get rid of stuff such as laptops audio in the dock? When exactly should I uninstall and reinstall them?

I haven't tried uninstalling every single audio device, but I have tried doing all the reinstalls with laptop disconnected from everything and still no luck :(

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Fri Mar 19, 2021 8:14 am
by Vincent Burel
it means 1- unplug USB device and reboot.

we have a new tools to help on this question here:

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Fri Mar 19, 2021 8:20 am
by RadekPilich
Thanks, of course I found it, but didn't help, it all looks good in there. I don't use Audio Cable (yet),just VoiceMeeter.

Re: Voicemeeter or Audio problem after WIN10 update

Posted: Fri Mar 26, 2021 7:29 pm
by RadekPilich
As expected the solution was to not do it all in one session but wait a day or two between uninstall and reinstall. Weird.