[Bug] "Normal mode" mix setting under Master Section not saving with .xml profile in Banana

The Virtual Audio Mixer discussions and support...
Post Reply
Tychoid
Posts: 2
Joined: Tue Dec 17, 2019 5:42 am

[Bug] "Normal mode" mix setting under Master Section not saving with .xml profile in Banana

Post by Tychoid »

I might be missing something, but I believe this is a bug. As the title states, the "Normal mode" mix setting under the MASTER SECTION is not saving with .xml profile.

Bug reproduction steps:
#1) Select "Normal mode" under A1 Output in the MASTER SECTION
#2) Save a settings profile (Menu -> Save Settings... -> Save .xml)
#3) Select "MIX down A" under A1 Output in the MASTER SECTION (or any other setting apart from "Normal mode")
#4) Load .xml profile from step #2 (Menu -> Load Settings... -> Load .xml)
--Note that "MIX down A" setting persists, and "Normal mode" was not saved in .xml profile. In contrast, any other mix settings under the MASTER SECTION are saved to xml profiles.
--The main problem this causes is that if you load a profile where you want channel up/downmixing, you cannot simply load another profile to revert back to Normal mode. You have to manually go into VMB to select Normal mode every time you change off of it.
Vincent Burel
Site Admin
Posts: 1429
Joined: Sun Jan 17, 2010 12:01 pm

Re: [Bug] "Normal mode" mix setting under Master Section not saving with .xml profile in Banana

Post by Vincent Burel »

right! there is a bug on the load process... we note it for the next version...
Post Reply